Closed Bug 839515 Opened 7 years ago Closed 7 years ago

Tiny fonts in the remote connection screen

Categories

(DevTools :: Framework, defect)

x86
macOS
defect
Not set

Tracking

(firefox21+ verified, firefox22+ verified)

VERIFIED FIXED
Firefox 23
Tracking Status
firefox21 + verified
firefox22 + verified

People

(Reporter: past, Assigned: past)

References

()

Details

(Keywords: regression, Whiteboard: [fixed-in-fx-team])

Attachments

(4 files)

Sometime the past few days the fonts in the remote connection screen (the one you get from the 'Connect...' menu item became really small. It is very evident in the host/port labels, but also in the target list after one connects to a remote instance.

My guess is that this is a regression from bug 826685, so CCing Paul and Mihai.
Attached the URL for the screenshot of the small font on connect screen.
Blocks: :PaulFx21
Duplicate of this bug: 855984
Attached patch Patch v1Splinter Review
My new glasses didn't improve the situation, so I really had to fix this, otherwise the connection screen was barely usable for me.

Tested on Lion, Mountain Lion, Ubuntu 12.10, Windows 7 and Windows XP: in all cases there was an improvement. Besides the tiny font, OS X has large round borders in the input box which need to be accompanied with larger horizontal padding.
Assignee: nobody → past
Status: NEW → ASSIGNED
Attachment #732737 - Flags: review?(jwalker)
I though the extra large inputs were just a side effect of the font size. They look kinda' funky to me.
Attachment #732737 - Flags: review?(jwalker) → review+
(In reply to Victor Porof [:vp] from comment #7)
> I though the extra large inputs were just a side effect of the font size.
> They look kinda' funky to me.

They don't feel that large in all operating systems, actually. My guess is that Paul tried to fill the large empty space somehow.

I'd rather not make non-obvious fixes/changes in this bug, though. Let's file followups for more UI tweaks.
https://hg.mozilla.org/mozilla-central/rev/66ed95d19a69
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Attached patch Patch for betaSplinter Review
This is the rebased patch for mozilla-beta.
Comment on attachment 735052 [details] [diff] [review]
Patch for beta

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 826685
User impact if declined: the remote connection screen and the remote targets list screen will have tiny fonts, making them barely usable to visually impaired people
Testing completed (on m-c, etc.): m-c, beta
Risk to taking this patch (and alternatives if risky): insignificant risk, styling changes only, in a single tab that will be used by web developers after flipping a pref (devtools.debugger.remote-enabled)
String or IDL/UUID changes made by this patch: none
Attachment #735052 - Flags: approval-mozilla-beta?
Comment on attachment 732737 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 826685
User impact if declined: the remote connection screen and the remote targets list screen will have tiny fonts, making them barely usable to visually impaired people
Testing completed (on m-c, etc.): m-c, aurora locally
Risk to taking this patch (and alternatives if risky): insignificant risk, styling changes only, in a single tab that will be used by web developers after flipping a pref (devtools.debugger.remote-enabled)
String or IDL/UUID changes made by this patch: none
Attachment #732737 - Flags: approval-mozilla-aurora?
Comment on attachment 735052 [details] [diff] [review]
Patch for beta

low risk, polish only.Approving for aurora,beta.
Attachment #735052 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #732737 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Verified as fixed on Firefox 21 beta 3 - 20130416200523.
While trying to verify this fix on Firefox 22, I noticed the following: although I set devtools.debugger.remote-enabled to true and restart Firefox, I don't get the remote debugger option in the Tools menu anymore (nor anywhere else). Is this expected? Is there another way I can get to the connect dialog?
To get the "Browser Debugger", you also need devtools.chrome.enabled since Browser Debugger runs in a separate process and is not simply a remote tool, like Style editor or profiler.
(In reply to Ioana Budnar, QA [:ioana] from comment #17)
> While trying to verify this fix on Firefox 22, I noticed the following:
> although I set devtools.debugger.remote-enabled to true and restart Firefox,
> I don't get the remote debugger option in the Tools menu anymore (nor
> anywhere else). Is this expected? Is there another way I can get to the
> connect dialog?

Yes, both Remote Debugger and Remote Console have been replaced by the 'Connect...' menu item mentioned in comment 0.
It's the "Connect" item I was referring to. For some reason it didn't show up until I restarted Firefox several time. I'm not sure what happened there, but I can't seem to reproduce it again.

I did verify this bug as Fixed on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:21.0) Gecko/20100101 Firefox/22.0 - 20130514181517.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.