Closed Bug 839569 Opened 7 years ago Closed 7 years ago

mozbase modules from tests.zip are not extracted during test time

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jmaher, Assigned: jmaher)

References

Details

Attachments

(1 file)

in order for our test harnesses to use mozbase modules, we need to unzip them, right now we only unzip things that are related to the harness:
http://hg.mozilla.org/build/buildbotcustom/file/9b23b69f1947/steps/misc.py#l274
Blocks: 823452
Blocks: 827446
Comment on attachment 711901 [details] [diff] [review]
add mozbase* to the subdirs we extra from the tests.zip file (1.0)

Review of attachment 711901 [details] [diff] [review]:
-----------------------------------------------------------------

Is mozbase supposed to be on all package tests for older branches as well?
Attachment #711901 - Flags: review?(armenzg) → review+
we won't be using it specifically, it is just when a testharness or tool needs to import it.  Are you concerned that there might be errors in unzipping mozbase* ?
http://hg.mozilla.org/build/buildbotcustom/rev/b3ba4d217f62

waiting for deployment before closing.
in production
Blocks: 840481
can we close this now?
Attachment #711901 - Flags: checked-in+
Yes. Thanks for your help!
Assignee: nobody → jmaher
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.