If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Refreshing when Developing with Localhost

RESOLVED DUPLICATE of bug 690307

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 690307
5 years ago
5 years ago

People

(Reporter: andiezing, Unassigned)

Tracking

18 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
developing on localhost is painful, because once you type in a url and push enter - to refresh / reload the page browser assumes the url which starts with "localhost/..." will do a google search instead of trying to reload the page.

My husband has requested I submit this for him. Let me know if you have questions. Thanks!  -Andrea
No bug report without a version number....

A google search can be a result of a webserver that rejects the connection or if your URL contains a space.
You can disable the keyword search in that case :
http://support.mozilla.org/en-US/kb/search-web-address-bar
Component: Toolbars → Untriaged
(Reporter)

Comment 2

5 years ago
Thanks for your help, Matthias, he found he did have a space. :)
Version: unspecified → 18 Branch
A space in the URL is bug 690307
instead of disabling the keyword search you can also disable the URL trim (removing the protocol in the front) :
browser.urlbar.trimURLs in about:config
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 690307
You need to log in before you can comment on or make changes to this bug.