Private browsing API/environments are broken for extensions in Firefox 21 (nightly)

RESOLVED DUPLICATE of bug 823941

Status

()

Firefox
Private Browsing
RESOLVED DUPLICATE of bug 823941
5 years ago
5 years ago

People

(Reporter: deltaburnt, Unassigned)

Tracking

({addon-compat, privacy})

21 Branch
x86_64
Windows 7
addon-compat, privacy
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130130 Firefox/21.0
Build ID: 20130130030907

Steps to reproduce:

I used a cookie editing extensions and attempted to write an extension that detects the presence of private browsing.


Actual results:

The cookie editing extensions failed to view the private window's private cookies and instead only saw the cookies of the main firefox profile. My extension that I attempted to write completely ignores the existence of private browsing:
  require("sdk/private-browsing").isActive
Is false even in a private window.


Expected results:

The cookie editing extension should be sandboxed to only the private window's environment (at least I'm assuming so) when run from the private window. Furthermore my code should detect whether private browsing is active when run from a private window (i.e. require("sdk/private-browsing")).
(Reporter)

Comment 1

5 years ago
For reference, the cookie editing extension I used was Cookies Manager+ 1.5.1.1
Component: Untriaged → Private Browsing
Keywords: addon-compat, privacy

Comment 2

5 years ago
As the issues you described are mainly about the failures of the cookie inspection, I'm going to dupe this to bug 823941 which would implement the infrastructure for what you want. The SDK-related problems are tracked by bug 748604.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 823941
You need to log in before you can comment on or make changes to this bug.