The monkey patch no longer works.

RESOLVED DUPLICATE of bug 839792

Status

()

RESOLVED DUPLICATE of bug 839792
6 years ago
6 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

({addon-compat, regression})

21 Branch
x86_64
Windows 7
addon-compat, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
The monkey patch no longer works.


Steps to Reproduce:
1. devtools.chrome.enabled = true
2. Open ScratchPad and check Environment > Browser
3. Execute the following

BrowserSearch.searchBar.rebuildPopup = function rebuildPopup(){};
alert(BrowserSearch.searchBar.rebuildPopup);

Actual Results:

function rebuildPopup() {

          var popup = this._popup;

          // Clear the popup, down to the first separator

** snip **
          this._needToBuildPopup = false;
        
}

Expected Results:

function rebuildPopup(){}

The method defined in xbl should be able to monkey patch.


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/dc11dee7fffb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130208 Firefox/21.0 ID:20130208061013
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b191b0790a66
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130208 Firefox/21.0 ID:20130208062616
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=dc11dee7fffb&tochange=b191b0790a66

Triggered by: Bug 821850
Blocks: 821850
Whiteboard: triggered by Bug 821850
Assignee: general → nobody
Component: JavaScript Engine → XBL
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
tracking-firefox21: ? → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 839792
You need to log in before you can comment on or make changes to this bug.