about:memory negative value for canvas-2d-pixel-bytes

NEW
Unassigned

Status

()

--
minor
6 years ago
2 years ago

People

(Reporter: mbimmler, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink:P3])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 712258 [details]
about:memory?verbose output with negative canvas-2d-pixel-bytes value

Firefox 18.0.2 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:18.0) Gecko/20100101 Firefox/18.0

When opening about:memory, I get the following warning:

WARNING: the following values are negative or unreasonably large.
 canvas-2d-pixel-bytes
This indicates a defect in one or more memory reporters.  The invalid values are highlighted.

Specifically, the value for canvas-2d-pixel-bytes is -22.93 MB

A full about:memory?verbose is attached.

Updated

6 years ago
Attachment #712258 - Attachment mime type: application/octet-stream → text/html
(Reporter)

Comment 1

6 years ago
I just noticed that there is an earlier RESOLVED:FIXED bug for this for Firefox 9:
https://bugzilla.mozilla.org/show_bug.cgi?id=686345

Updated

6 years ago
Whiteboard: [MemShrink]

Updated

6 years ago
Component: Untriaged → about:memory
Product: Firefox → Toolkit
Whiteboard: [MemShrink] → [MemShrink:P3]
I am seeing a negative canvas-2d-pixels on Nightly 28 (OS X 10.9). I have a memory-report.json if someone wants to look at it. (I would rather not attach it to a public bug report.)
Version: 18 Branch → Trunk
No need for the full memory-report.json, but knowing the actual negative value would be interesting.  Thanks.
  -15,465,632 B ── canvas-2d-pixels [?!]
    1,460,256 B ── gfx-surface-image
           76 B ── gfx-surface-quartz
            0 B ── gfx-textures
              0 ── ghost-windows
  384,460,168 B ── heap-allocated
  444,452,864 B ── heap-committed
         15.52% ── heap-overhead-ratio
              0 ── host-object-urls
        7,440 B ── imagelib-surface-cache
    3,641,344 B ── js-main-runtime-temporary-peak
          5,085 ── page-faults-hard
     15,573,982 ── page-faults-soft
  849,121,280 B ── resident
5,006,364,672 B ── vsize

Comment 5

4 years ago
I am also running into this problem, likely from this website: http://a.singlediv.com/

here's the report. 

934,609,720 B (100.0%) -- window-objects
├──596,170,880 B (63.79%) -- layout
│  ├──438,671,296 B (46.94%) ── style-sets
│  ├───62,677,168 B (06.71%) ── frames
│  ├───51,948,376 B (05.56%) ── pres-shell
│  ├───13,936,336 B (01.49%) ── pres-contexts
│  ├───13,678,720 B (01.46%) ── style-contexts
│  ├────8,987,400 B (00.96%) ── rule-nodes
│  ├────5,779,120 B (00.62%) ── line-boxes
│  └──────492,464 B (00.05%) ── text-runs
├──214,318,496 B (22.93%) -- dom
│  ├──128,543,808 B (13.75%) ── element-nodes
│  ├───54,367,680 B (05.82%) ── orphan-nodes
│  ├───18,939,968 B (02.03%) ── text-nodes
│  ├────9,982,736 B (01.07%) ── other
│  ├────1,937,920 B (00.21%) ── event-targets
│  ├──────546,384 B (00.06%) ── comment-nodes
│  └────────────0 B (00.00%) ── cdata-nodes
├──123,180,920 B (13.18%) ── style-sheets
└──────939,424 B (00.10%) ── property-tables

  -11,385,932 B ── canvas-2d-pixels [?!]
           76 B ── gfx-surface-quartz
            0 B ── gfx-textures
              0 ── ghost-windows
2,308,475,136 B ── heap-allocated
2,443,698,176 B ── heap-committed
          5.85% ── heap-overhead-ratio
              0 ── host-object-urls
        7,440 B ── imagelib-surface-cache
    9,129,984 B ── js-main-runtime-temporary-peak
         40,955 ── page-faults-hard
  1,483,215,450 ── page-faults-soft
3,489,673,216 B ── resident
8,656,478,208 B ── vsize
> I am also running into this problem, likely from this website: http://a.singlediv.com/

Thank you for the data. I don't think that site can be the cause because it doesn't use <canvas> elements.

Comment 7

4 years ago
I'm also seeing this on Firefox 32.0, Windows 7.

 -7.40 MB ── canvas-2d-pixels [?!]
    0.00 MB ── gfx-d2d-surface-cache
    4.00 MB ── gfx-d2d-surface-vram
    9.02 MB ── gfx-d2d-vram-draw-target
    1.01 MB ── gfx-d2d-vram-source-surface
    0.89 MB ── gfx-surface-win32
    0.00 MB ── gfx-textures
          0 ── ghost-windows
   34.95 MB ── gpu-committed
   35.07 MB ── gpu-dedicated
    4.98 MB ── gpu-shared
  239.84 MB ── heap-allocated
        345 ── heap-chunks
    1.00 MB ── heap-chunksize
  245.76 MB ── heap-committed
  345.00 MB ── heap-mapped
      2.46% ── heap-overhead-ratio
          0 ── host-object-urls
    0.00 MB ── imagelib-surface-cache
    9.41 MB ── js-main-runtime-temporary-peak
          0 ── low-commit-space-events
  637.66 MB ── private
  644.07 MB ── resident
    0.00 MB ── shmem-allocated
    0.00 MB ── shmem-mapped
1,157.75 MB ── vsize
1,805.94 MB ── vsize-max-contiguous







Application Basics
------------------

Name: Firefox
Version: 32.0
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Adblock Plus
Version: 2.6.4
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Ghostery
Version: 5.3.2
Enabled: true
ID: firefox@ghostery.com

Graphics
--------

Adapter Description: NVIDIA NVS 4200M
Adapter Description (GPU #2): Intel(R) HD Graphics 3000
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter Drivers (GPU #2): igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter RAM: 512
Adapter RAM (GPU #2): Unknown
Device ID: 0x1056
Device ID (GPU #2): 0x0126
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.16571)
Driver Date: 8-4-2014
Driver Date (GPU #2): 3-20-2014
Driver Version: 9.18.13.4066
Driver Version (GPU #2): 9.17.10.3517
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 10
Vendor ID: 0x10de
Vendor ID (GPU #2): 0x8086
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA NVS 4200M Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: false
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.frecency_experiment: 4
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20140825202822
browser.startup.homepage_override.buildID: 20140825202822
browser.startup.homepage_override.mstone: ignore
browser.tabs.drawInTitlebar: false
dom.mozApps.used: true
extensions.lastAppVersion: 32.0
gfx.direct3d.last_used_feature_level_idx: 0
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1409838205
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_bgcolor: false
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_bgimages: false
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_colorspace:
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_command:
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_downloadfonts: false
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_duplex: 1515870810
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_edge_bottom: 0
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_edge_left: 0
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_edge_right: 0
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_edge_top: 0
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_evenpages: true
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_in_color: true
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_margin_bottom: 0.5
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_margin_left: 0.5
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_margin_right: 0.5
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_margin_top: 0.5
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_oddpages: true
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_orientation: 0
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_page_delay: 50
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_paper_data: 1
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_paper_height: 11.00
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_paper_name:
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_paper_size_type: 0
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_paper_size_unit: 0
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_paper_width: 8.50
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_plex_name:
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_resolution: 1515870810
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_resolution_name:
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_reversed: false
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_scaling: 1.00
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_shrink_to_fit: true
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_to_file: false
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_unwriteable_margin_bottom: 0
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_unwriteable_margin_left: 0
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_unwriteable_margin_right: 0
print.printer_\\AGO-PRINTERS.ara.wan\VTK_Copy_Room_SHARP_MX-2600N.print_unwriteable_margin_top: 0
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.index: 0

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.6
Version in use: 4.10.6

NSS
Expected minimum version: 3.16.4 Basic ECC
Version in use: 3.16.4 Basic ECC

NSSSMIME
Expected minimum version: 3.16.4 Basic ECC
Version in use: 3.16.4 Basic ECC

NSSSSL
Expected minimum version: 3.16.4 Basic ECC
Version in use: 3.16.4 Basic ECC

NSSUTIL
Expected minimum version: 3.16.4
Version in use: 3.16.4

Experimental Features
---------------------

Comment 8

2 years ago
Still here in Nightly 51.0a1 on x86_64:

 -674.62 MB ── canvas-2d-pixels [?!]
You need to log in before you can comment on or make changes to this bug.