Closed Bug 839887 Opened 7 years ago Closed 7 years ago

Regression: Selecting a Synced tab, opens the regular tab menu

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 21
Tracking Status
firefox20 --- fixed
firefox21 --- fixed
relnote-firefox --- -
fennec 20+ ---

People

(Reporter: aaronmt, Assigned: sriram)

References

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

Currently when one selects a synced tab, the regular tab menu will open and the tab panel does not close.

--
Nightly (02/10)
LG Nexus 4 (Android 4.2)
QA Contact: aaron.train
Let's fix this soon since it is in Aurora too
Assignee: nobody → sriram
Attached patch PatchSplinter Review
Wrong threading :(
areTabsShown() was accessing a stale value from a different thread, before the animation was bound to happen. So, that caused the SELECTED tab event to queue up a showTabs().
Attachment #713608 - Flags: review?(mark.finkle)
Attachment #713608 - Flags: review?(mark.finkle) → review+
Comment on attachment 713608 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Patch to switch between normal and private tabs on tablets.
User impact if declined: Selecting the synced tab will open the tab, close the tabs ui, and open it again.
Testing completed (on m-c, etc.): Landed in m-i on 02/14
Risk to taking this patch (and alternatives if risky): None. Made sure the thread access is right.
String or UUID changes made by this patch: None.
Attachment #713608 - Flags: approval-mozilla-aurora?
tracking-fennec: ? → 20+
https://hg.mozilla.org/mozilla-central/rev/265796431ef9
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
(In reply to Sriram Ramasubramanian [:sriram] from comment #4)
> Comment on attachment 713608 [details] [diff] [review]
> Patch
> 
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): Patch to switch between normal and
> private tabs on tablets.

regressing bug# : https://bugzilla.mozilla.org/show_bug.cgi?id=834399
Blocks: 834399
Comment on attachment 713608 [details] [diff] [review]
Patch

Low risk fix for a Fx20 regression. Approving on Aurora.PLease land before 2/18.

Adding verifyme and requesting QA verification here . Thanks !
Attachment #713608 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
This is fixed on every channel before it made it to beta. I don't think we need to relnote this.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.