Not possible to dial to two digits MSISDN's from Dialer app

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: dpalomino, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Hi, 

We've observed that from Dialer it is not possible to dial to two-digit MSISDNs. The call is not even attempted and no error message is displayed to the user. 

It is important to be able to call to this short MSISDNs as some voice mail MSISDNs are composed by just two digits. For instance, for Venezuela the number to call to mailbox is "*2". 

Nominating it as tef? and adding dependency to certification meta bug, as this is a certification blocker. 

Thanks!
David
Hi David, using Gecko-8ed37c2.Gaia-21cedfd , (at least in Spain using a Movistar SIM) the device tries to establish the call but the RIL notifies a "call disconnected" event (probably because it is not able to establish that kind of calls) and consequently the outgoing attention screen is closed ;-) Isn't this the expected behavior?
Flags: needinfo?(dpv)
(Reporter)

Comment 2

6 years ago
Hi Guillermo, 

Just to doublecheck, I think we should test with Venezuela's SIM card. Tested with iOS, with Spanish SIM card, takes longer to disconnect the call. I'm not sure if this would work in Venezuela...
Flags: needinfo?(dpv)
Hi Beatriz, do we have a SIM Venezuelan card available? :-) Thanks!
Flags: needinfo?(brg)
(In reply to gtorodelvalle from comment #3)
> Hi Beatriz, do we have a SIM Venezuelan card available? :-) Thanks!
I am so sorry to tell you that we do not have any Venezuela SIM card.

We will discuss which is the best way to unlock this issue.
Flags: needinfo?(brg)

Comment 5

6 years ago
Daniel is going to verify whether this is an issue with the Mozilla RIL or QC RIL, before determining whether or not this blocks.
Flags: needinfo?(dcoloma)
Duplicate of this bug: 842248
(Reporter)

Comment 7

6 years ago
Hi, 

This has been retested with Ikura, QC RIL, and it was working. 

We think we can close this issue, and if seen again (or with other device), it could be reopened. 

Thanks!
David
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(dcoloma)
Resolution: --- → WORKSFORME

Updated

6 years ago
Blocks: 840462
blocking-b2g: tef? → ---
You need to log in before you can comment on or make changes to this bug.