Last Comment Bug 839979 - Implement Object.is
: Implement Object.is
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: mozilla22
Assigned To: AWAY Tom Schuster [:evilpie]
:
Mentors:
Depends on:
Blocks: es6
  Show dependency treegraph
 
Reported: 2013-02-11 01:54 PST by David Bruant
Modified: 2013-05-31 14:13 PDT (History)
3 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (3.11 KB, patch)
2013-03-16 11:46 PDT, AWAY Tom Schuster [:evilpie]
no flags Details | Diff | Splinter Review
v2 (3.12 KB, patch)
2013-03-17 14:59 PDT, AWAY Tom Schuster [:evilpie]
jorendorff: review+
Details | Diff | Splinter Review

Description David Bruant 2013-02-11 01:54:50 PST
Per TC39 January 2013 meeting [1], is/isnt are out as operators, but Object.is remains (no need for Object.isnt, ! is enough for negation)

[1] https://github.com/rwldrn/tc39-notes/blob/master/es6/2013-01/jan-29.md#41-isisnt-operators
Comment 1 AWAY Tom Schuster [:evilpie] 2013-03-15 16:03:10 PDT
I implemented these as |is| and |isnt| before, taking.
Comment 2 AWAY Tom Schuster [:evilpie] 2013-03-16 11:46:22 PDT
Created attachment 725793 [details] [diff] [review]
v1

I took some ideas for tests from bug 715359. The rest is pretty straight forward, except maybe the args.length() < 2, because this is actually not clearly defined. So I made a post to es-discuss.
Comment 3 AWAY Tom Schuster [:evilpie] 2013-03-16 17:11:24 PDT
For some reason I confused myself more than I should have here. The args.length() < 2 should not return false here. New patch coming up.
Comment 4 AWAY Tom Schuster [:evilpie] 2013-03-17 14:59:58 PDT
Created attachment 725938 [details] [diff] [review]
v2

This now has the right behavior.
Comment 5 Jason Orendorff [:jorendorff] 2013-03-21 19:41:56 PDT
Comment on attachment 725938 [details] [diff] [review]
v2

Review of attachment 725938 [details] [diff] [review]:
-----------------------------------------------------------------

Beautiful!
Comment 6 AWAY Tom Schuster [:evilpie] 2013-03-28 10:53:52 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/a321bf04c39b
Comment 7 Ryan VanderMeulen [:RyanVM] 2013-03-28 18:03:54 PDT
https://hg.mozilla.org/mozilla-central/rev/a321bf04c39b

Note You need to log in before you can comment on or make changes to this bug.