Closed Bug 840077 Opened 7 years ago Closed 7 years ago

Firefox crashes using minified GoJS library

Categories

(Core :: JavaScript Engine, defect, critical)

18 Branch
All
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 830063
Tracking Status
firefox18 --- affected
firefox19 --- affected
firefox20 --- unaffected
firefox21 --- unaffected

People

(Reporter: simon.sarris, Unassigned)

References

()

Details

(Keywords: crash, reproducible)

Crash Data

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.30 (KHTML, like Gecko) Chrome/26.0.1403.0 Safari/537.30

Steps to reproduce:

This is possibly Windows-only

Open the page:

http://www.gojs.net/latest/samples/flowchart.html

Spot the "Finely chop..." node

Click on it and begin to drag it to the right


Actual results:

Firefox immediately crashes


Expected results:

The node should have been dragged to the right. This works in all other browsers, and works in Firefox 20.0a2

I'm the creator of the GoJS library, and several of my users have also reported this bug.
If firebug is installed and script debugging enabled, the crash does not occur.
It crashes in 18.0.2 (see bp-56fa519c-88e4-4a63-b15c-670132130211), but not in 19.0 Beta, 20.0a2 and 21.0a1.
Firefox 19.0 is going to be released on February 19.
Assignee: nobody → general
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Crash Signature: [@ js::ion::MNode::replaceOperand(unsigned int, js::ion::MDefinition*)]
Closed: 7 years ago
Component: Untriaged → JavaScript Engine
Keywords: crash, reproducible
OS: Windows 8 → Windows 7
Product: Firefox → Core
Hardware: x86_64 → All
Resolution: --- → WORKSFORME
Crashed
http://hg.mozilla.org/releases/mozilla-beta/rev/ddedca74a489
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20130209 Firefox/19.0 ID:20130209080412
I too just tried the 19.0 Beta and it crashed, doing the same operation (dragging the "Finely chop" node)
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 830063
Even if we knew the patch that has fixed those crashes, it would be too late in the Beta cycle to uplift it in 19.0 Beta, especially with such a low volume (only 34 crashes in 18.0.2 over the last week).
You must wait version 20.0 that is going to be released on April 2nd.
You need to log in before you can comment on or make changes to this bug.