Closed Bug 840095 Opened 7 years ago Closed 11 months ago

Gecko profiler often fails to retrieve profiles

Categories

(Core :: Gecko Profiler, defect, P3)

21 Branch
x86
macOS
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: kats, Unassigned)

References

(Blocks 3 open bugs)

Details

(Whiteboard: [gaming-tools])

I often try to profile a slow page (e.g. bug 816209, bug 806330 comment 10) but fail to do so. I can start up fennec (nightly) and connect the profiler just fine, but when I hit the analyze button to grab the profile it just hangs on the "retrieving profile" screen. This generally seems to happen on the pages that need profiling the most.

Perhaps with the multi-thread support for the profiler it could be possible to move the profiler code in Gecko off the main thread so that it doesn't depend on Gecko being responsive.
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #0)
> Perhaps with the multi-thread support for the profiler it could be possible
> to move the profiler code in Gecko off the main thread so that it doesn't
> depend on Gecko being responsive.

The multi-thread support wont help but in the case where the failures are caused by OOM it will make the failures worse since we're sending more data.

The first step is finding out exactly where the failure is. Perhaps adding more logging would help. Two bugs that will most likely help solve this bug is bug 797639 and getting disconnect event from the RDP which I can't find the bug number.
Depends on: 797639
Blocks: 846233
Summary: Gecko profiler often fails to retreive profiles → Gecko profiler often fails to retrieve profiles
Duplicate of this bug: 943965
Priority: -- → P3
Whiteboard: [gaming-tools]
Blocks: 1329163
Using https://perf-html.io/docs/#/./guide-remote-profiling things seem to work much better!
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.