Crypt demo broken on nightly (21)

VERIFIED FIXED in Firefox 21

Status

()

defect
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: vlad, Unassigned)

Tracking

(Blocks 1 bug, {regression})

21 Branch
mozilla21
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox21+ fixed, firefox32 verified)

Details

(Whiteboard: [games:p1], )

Attachments

(2 attachments)

The crypt demo starts to run OK, but after about 2-3 seconds it starts rendering basically without any textures.   Sometimes it works ok.  Useful STR seem to be:

1. Run firefox
2. Shift-control-k to bring up JS console
3. Load crypt from URL
Desperately could use a regression window on this.  I suspect in the past few weeks.
I just bisected this to:

Last good nightly: 2013-01-27
First bad nightly: 2013-01-28

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f18b12139151&tochange=80fed51ae074
In that range:

        Benoit Jacob — Bug 832576 - Fix perf regression in WebGL uniform setters - r=jgilbert 
	Benoit Jacob — Bug 827170 - Clamp intermediate surface's framebuffer dimensions to what is supported by the GL - r=BenWa Without this, we have assertion failures as we fail to create our textures and subsequently we have incomplete framebuffers. The present patch is a short-term compromise: to avoid asserting, we just clamp texture sizes. That can result in fuzzy rendering. Ideally (with some suitable tiling) we wouldn't have to do that.

Comment 4

6 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/aafdf3566582
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130127 Firefox/21.0 ID:20130127100708
Bad:
http://hg.mozilla.org/mozilla-central/rev/63685729b771
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130127 Firefox/21.0 ID:20130127160908
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=aafdf3566582&tochange=63685729b771


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d802d6faa080
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130126 Firefox/21.0 ID:20130126110610
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/e6d6b014a076
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130126 Firefox/21.0 ID:20130126122209
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d802d6faa080&tochange=e6d6b014a076

Triggered by: 
  e6d6b014a076	Brian Hackett — Bug 832364 - Generate optimized paths for element accesses on native objects, r=jandem.


Setting javascript.options.ion.content = false helps
Assignee: nobody → general
Blocks: 832364
Component: Canvas: WebGL → JavaScript Engine
Version: unspecified → 21 Branch

Updated

6 years ago
Severity: critical → normal
Whiteboard: [games:p1]
Posted patch patchSplinter Review
This patch seems to fix the site.  The problem was that object initializers with sparse indexed properties did not have type information indicating the presence of the sparse indexes, so that when we compiled 'in' operations (or other indexed operations) on those objects the compiled code could ignore the sparse indexes and behave incorrectly.
Attachment #713656 - Flags: review?(jdemooij)
Attachment #713656 - Flags: review?(jdemooij) → review+
https://hg.mozilla.org/mozilla-central/rev/45a3acbb9d57
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
http://crypt-webgl.unigine.com/ works fine in 32.0a1 (2014-05-18), win 7 x64
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.