The default bug view has changed. See this FAQ.

Shift+Del to cut links from location bar doesn't prepend http:// to the URL

RESOLVED DUPLICATE of bug 722813

Status

()

Firefox
Location Bar
RESOLVED DUPLICATE of bug 722813
4 years ago
3 years ago

People

(Reporter: ranunculoid, Unassigned)

Tracking

20 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20131111])

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130208042018

Steps to reproduce:

visited an http web page (not https)
clicked on URL bar
pressed Shift+Del
opened Notepad
pressed Shift+Ins


Actual results:

The contents of the URL bar (which did not include “http”) was pasted into Notepad /verbatim/.


Expected results:

“http” should have been added somehow, or shown in the URL bar to begin with.
(Reporter)

Comment 1

4 years ago
My user agent is different because of the Blender add-on. I am running 20.0a2.

Comment 2

4 years ago
This apparently has to do with the way you're copying. When using right click > copy or ctrl-c, the http:// is added. You can also disable the feature of hiding http:// by going to about:config and setting browser.urlbar.trimURLs to false.

Apart from those workarounds, this of course looks like a valid bug (I can reproduce). If you set the component to "Location bar" in the bug details, a developer will probably notice it easier :)
(Reporter)

Updated

4 years ago
Component: Untriaged → Location Bar

Comment 3

4 years ago
bug 666964 fixed this for Ctrl C copying, changing the summary to reflect the key combo mentioned in comment 0.

The current workaround is to go to about:config and change the value of
browser.urlbar.trimURLs
to false

Updated

4 years ago
Summary: “http://” is missing from the URL bar and this means when I copy links I need to add it back in manually if I want them clickable → Shift+Del to copy links from location bar doesn't prepend http:// to the URL
(Reporter)

Comment 4

4 years ago
Thanks Mardeg.

Updated

4 years ago
Blocks: 665580
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

4 years ago
Summary: Shift+Del to copy links from location bar doesn't prepend http:// to the URL → Shift+Del to cut links from location bar doesn't prepend http:// to the URL

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Whiteboard: [bugday-20131111]
Duplicate of bug: 722813

Updated

3 years ago
No longer blocks: 665580
You need to log in before you can comment on or make changes to this bug.