[B2G][Here Map] Route – By default any route gives a result in walk distance.

RESOLVED FIXED

Status

Tech Evangelism
Preinstalled B2G Apps
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sarsenyev, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [apps watch list1])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 713030 [details]
bug02.12.13

Description:
When you search for any direction (map or turn by turn direction), it gives you the result in walk distance. For an example: Walking distance is 31.2ml, 10.5hr
Driving distance is choosing manually.

Steps to reproduce:
1. Update phone with build ID:20130212070205
2. Make sure that GPS is "ON" by default (Settings-Network & Connectivity-GPS) 
3. Open “Here Maps” app.
4. If it’s opened for a first time, the first page will ask “Here Maps would like to know your location”, click “Allow”
5. Wait until the “Here Maps” will find your location.
6. In the second address field type any address.

Actual result:
The address is found and the route gives the result in walk distance.

Expected result:
The address is founded and calculated and gives the result by default in driving distance (with manually choice options of driving, walking, riding a bus) 

Repro'ed frequency:
(5/5, 100%)

Notes:
Build ID:20130212070205
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/3f905f0ca9ce
Gaia   ecca2ee860825547d5e1109436b50b74dfe9261e
Kernel: Dec5
See the attachment.

Updated

5 years ago
Blocks: 837298

Comment 1

5 years ago
This is by design, but we will change this - it is part of our ui changes that will come soon. I will discuss the details with Donovan Preston.

Updated

5 years ago
Component: Gaia → Preinstalled B2G Apps
Product: Boot2Gecko → Tech Evangelism
Version: unspecified → Trunk

Updated

5 years ago
Whiteboard: [apps watch list]

Updated

5 years ago
Whiteboard: [apps watch list] → [apps watch list1]

Comment 2

5 years ago
Donovan, can you provide an update on this bug?
Flags: needinfo?(dpreston)
This is now fixed in 1.8.58 of maps running on 1.0.1 unagi 20130522
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(dpreston)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.