Adblock settings missbehaving

VERIFIED FIXED in Firefox 22

Status

()

Firefox for Android
Add-on Manager
VERIFIED FIXED
5 years ago
a year ago

People

(Reporter: micmon, Assigned: wesj)

Tracking

20 Branch
Firefox 22
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Pressing the "filter subscription" list button in Adblock settings does not show the list most of the time, it just darkens the screen.

In very rare cases (one in 20 maybe) the llist is actually displayed. Pressing one item selects the item above it, which will not be the value shown in the list button. However, there is now way to actually save this, pressing "back" reverts the value to "Easylist".
I'm able to reproduce this on all channels.
tracking-fennec: --- → ?
Assignee: nobody → wjohnston
tracking-fennec: ? → +
(Assignee)

Comment 2

5 years ago
Created attachment 716762 [details] [diff] [review]
Patch

I am not entirely sure what's going wrong here. AFAICT, Adblock ships a control that looks like:

  <setting type="control" title="&subscriptions.tab.label;">
    <menulist id="adblockplus-subscription-list"/>
  </setting>

and fills in the list at some point, so I think this may be a race. I also realized we really don't need this binding for menulist anymore though. SelectHelper already intercepts clicks for us, and the rest of the code in there seemed to be for hiding the gtk popup, which we no longer show anyway?

Removing that binding seems to fix the problem for me. I wonder if our binding and click handling was interfering with adblock creating the filter list?
Attachment #716762 - Flags: review?(mbrubeck)
Comment on attachment 716762 [details] [diff] [review]
Patch

Looks good to me.  I think the click-handling here was only needed for <menulist> elements in browser chrome (which /mobile/android no longer uses).  For in-content UI like the add-on manager, SelectHelper's event handling is all we need.
Attachment #716762 - Flags: review?(mbrubeck) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/6271f9482ede

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/6271f9482ede
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22

Comment 6

5 years ago
I am not able to verify this issue, due to Bug 847002
Depends on: 847002

Comment 7

5 years ago
(In reply to Andreea Pod from comment #6)
> I am not able to verify this issue, due to Bug 847002
You can in builds between February 25th and 28th.
No longer depends on: 847002

Comment 8

5 years ago
Verified fixed on:
-build: Firefox for Android 22.0a1 (2013-02-27)
-device: Samsung Galaxy Nexus
-OS: Android 4.1.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.