Crash with undoManager, removing document.documentElement

RESOLVED FIXED in mozilla24

Status

()

Core
DOM
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Jesse Ruderman, Assigned: wchen)

Tracking

({crash, regression, testcase})

Trunk
mozilla24
crash, regression, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox19 unaffected, firefox20 affected, firefox21 affected)

Details

(crash signature)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 713288 [details]
testcase (crashes Firefox when loaded)

With:
  user_pref("dom.undo_manager.enabled", true);

Crash [@ UndoMutationObserver::IsManagerForMutation] due to null undoManager.
(Reporter)

Comment 1

5 years ago
Created attachment 713289 [details]
stack

Comment 2

5 years ago
On Windows: bp-33f7c0b6-ce9f-46f3-8383-b25382130213
Crash Signature: [@ UndoMutationObserver::IsManagerForMutation(nsIContent*)]
status-firefox19: --- → unaffected
status-firefox20: --- → affected
status-firefox21: --- → affected
Keywords: regression
OS: Mac OS X → All
Hardware: x86_64 → All
(Assignee)

Updated

5 years ago
Assignee: nobody → wchen
(Reporter)

Comment 3

5 years ago
Related to bug 872870?
(Assignee)

Comment 4

5 years ago
Created attachment 761023 [details] [diff] [review]
Handle null undoManager in absence of documentElement.
Attachment #761023 - Flags: review?(ehsan)

Updated

5 years ago
Attachment #761023 - Flags: review?(ehsan) → review+

Comment 6

5 years ago
https://hg.mozilla.org/mozilla-central/rev/022cb8f500a8
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
You need to log in before you can comment on or make changes to this bug.