Real bad scrolling on Padfone 2

RESOLVED DUPLICATE of bug 805479

Status

()

Firefox for Android
Toolbar
RESOLVED DUPLICATE of bug 805479
5 years ago
5 years ago

People

(Reporter: stefan.mueller.83, Unassigned)

Tracking

18 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130201065344

Steps to reproduce:

Tried to scroll on some web pages as in the default browser or chrome. 
I tried slow scrolling with finger touched and slowly moved and than lifted from the screen as well as fast scrolling, trying to drag the page and fling to the lower or upper end from multiple position within a page.
A couple of days I installed he newest firmware update but no change, as described below.


Actual results:

When I scroll slowly it works fine but as soon as I try to fling it scrolls a little little bit into the desired direction but then the motion reverses and the site sometimes scrolls until to the end of the pager.
It seems to work a bit better when I scroll on the phone instead of the pad.
Is seems to be similar as described in bug 758970



Expected results:

normal scroll, fling behaviour as in any other app on my Padfone 2.
Can u proivide me the logtouchevents.apk, because this link is down
https://people.mozilla.com/~kgupta/tmp/logtouchevents.apk, so I can provide some log files.
I've pushed a new try build with the logging I'd like, I'll link to the build once it's done. Try build is at https://tbpl.mozilla.org/?tree=Try&rev=894d2db329e6

stefan, is there any behaviour you're seeing that's not covered by bug 805479? If not we should dupe this bug there.
Try build is at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/kgupta@mozilla.com-894d2db329e6/try-android/fennec-21.0a1.en-US.android-arm.apk - it will show up as "Nightly" on the device. Please use this to reproduce the problem, and then get the log using "adb logcat -v time" if possible. If your device has an Android version earlier than 4.1 you can also get the log using the aLogcat app in the play store - see https://wiki.mozilla.org/Mobile/Fennec/Android#Using_aLogCat for details on that.
(Reporter)

Comment 3

5 years ago
Hoi,
thx for that quick response.
I installed fennec-21.0a1 and is running fine. I noticed that scrolling works quite well on the phone, sometimes is just a bit slow/delayed. Just for verification I tried FF 18 and is quite the same, may this is due to the firmware update, so I have to correct my initial statement. 
But on the PAD is still as worse as it was before. 
The bad news is that the logging is not working, I tried aLocgat, aLogrec and CatLog but only CatLog is showing me the logs but "adb logcat -v time" result in an empty screen. I run on Android 4.1.1 but there is an workaround for aLogcat, converting it in a system App but Apps2ROM and /system/app are not working on my phone. 
So any advice how to log FF?

Regarding [url=https://bugzilla.mozilla.org/show_bug.cgi?id=805479]bug 805479[/url], the behaviour is pretty much the same and as mentioned there, only in FF.
(In reply to stefan.mueller.83 from comment #3)
> I tried aLocgat, aLogrec
> and CatLog but only CatLog is showing me the logs but "adb logcat -v time"
> result in an empty screen.

If CatLog shows you the log, can you extract it from there? If not I'm working on a solution to extract logs on demand using an add-on. Once that's done I'll let you know.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 805479
(Reporter)

Comment 6

5 years ago
Created attachment 714867 [details]
log file when in phone mode
(Reporter)

Comment 7

5 years ago
Created attachment 714868 [details]
log file when in pad mode
(Reporter)

Comment 8

5 years ago
so finally I have got the log files, but not filtered since I wasn't able to find a prober desktop log viewer.
Anyway, there's one log for the phone and pad each. The behaviour on the phone isn't nearly that distinctive than on the pad.
As with bug 805479, I see some crazy input events being reported on the "pad mode" log file. For example:

Received event: MotionEvent { action=ACTION_MOVE, id[0]=0, x[0]=457.21237, y[0]=940.68475 }
y-axis velocity is 18.732769
y-axis velocity is 20.755909
y-axis velocity is 21.254051
Received event: MotionEvent { action=ACTION_MOVE, id[0]=0, x[0]=465.32007, y[0]=893.3788 }
y-axis velocity is 23.29444
y-axis velocity is 25.530704
Received event: MotionEvent { action=ACTION_MOVE, id[0]=0, x[0]=477.0032, y[0]=835.2463 }
y-axis velocity is 25.837072
y-axis velocity is 28.627476
y-axis velocity is 30.345123
Received event: MotionEvent { action=ACTION_MOVE, id[0]=0, x[0]=512.7514, y[0]=664.92926 }
y-axis velocity is 31.80169
y-axis velocity is 35.23627
y-axis velocity is 36.504776
Received event: MotionEvent { action=ACTION_MOVE, id[0]=0, x[0]=502.08194, y[0]=716.50665 }
y-axis velocity is -134.5715
y-axis velocity is -120.03778
y-axis velocity is -118.59733
Received event: MotionEvent { action=ACTION_UP, id[0]=0, x[0]=502.08194, y[0]=716.50665 }
During fling, y-axis velocity is -115.03941
During fling, y-axis velocity is -111.588234
During fling, y-axis velocity is -108.24059

The y[0] value is decreasing relatively smoothly from 940 to 835, then jumps to 664 before going back to 716 (where the last touchmove and touch-up happen). This causes the velocity to change from around 35 to -134, sending the fling in the wrong direction.

I wonder if this is related to the "predictive touch events" that were added in Jelly Bean? AFAIK this issue is only being reported on Jelly Bean devices.
You need to log in before you can comment on or make changes to this bug.