www.nextbuses.mobi serves WAP to Firefox on Android

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: c.j.hodges, Assigned: karlcow, Mentored)

Tracking

Firefox 18
ARM
Android

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [contactready] [serversniff] [country-uk], URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

Enter the web address:
www.nextbuses.mobi
(or load the same site, or a page on that site, from a bookmark)

This is in 18.0.2 on a motorola defy+


Actual results:

I get a notification (random).part has finished downloading and a popup window:
"Complete action using
 Browser
 HTML Viewer
[] Use by default for this action"
If I check my downloads folder, the page has been saved as a file, without a .htm or .html extension.  If I then rename the file to something.htm, I can open it in my choice of  browser, firefox (which now works) etc.



Expected results:

The page should be rendered in firefox
$ curl -ILA "Mozilla/5.0 (Android; Mobile; rv:20.0) Gecko/20.0 Firefox/20.0" www.nextbuses.mobi
HTTP/1.1 200 OK
Cache-Control: private
Content-Length: 1925
Content-Type: application/vnd.wap.xhtml+xml; charset=utf-8
Server: Microsoft-IIS/7.0
X-AspNetMvc-Version: 2.0
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET
Date: Wed, 13 Feb 2013 15:59:02 GMT

They are serving up a WAP page to Firefox for Android.

Feel free to send an email to the web author of the site to tell them that Firefox for Android is a modern browser and for them to recognize that our browser is more than capable of rendering their site.
Status: UNCONFIRMED → NEW
Component: General → Mobile
Ever confirmed: true
OS: Windows XP → Android
Product: Firefox for Android → Tech Evangelism
Hardware: x86 → ARM
Summary: Page downloads instead of rendering → www.nextbuses.mobi serves WAP to Firefox on Android
(Reporter)

Comment 2

6 years ago
Thanks Aaron - I have, but I don't hold out much hope - it's a local government / public transport consortium who run the site.

I had a quick look through the downloaded file, but don't know enough about html headers to find the giveaway.

In the mean time I'll try the UAControl addon.

Thanks again

Chris
(Assignee)

Comment 3

5 years ago
contactform
The feedback page is at http://nextbuses.mobi/WebView/Feedback/Feedback
The site has been made by http://www.mxdata.co.uk/

Sent an email on the feedback form.
Assignee: nobody → kdubost
Whiteboard: [sitewait] [serversniff] [country-uk]
(Assignee)

Updated

5 years ago
See Also: → bug 941241
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

4 years ago
contacttwitter
I got no reply at the first attempt :/

Trying to contact the CTO.
http://twitter.com/MozWebCompat/status/451978125694353408
http://www.linkedin.com/pub/michael-cliffe/b/216/8a1
(Assignee)

Updated

4 years ago
Whiteboard: [sitewait] [serversniff] [country-uk] → [sitewait] [serversniff] [country-uk] [mentor=kdubost]

Comment 5

4 years ago
Hi Karl,

Apologies you got no response via our front door.

We manage this site on behalf of a client.  This is now on their backlog which will go into the next sprint planning session to be prioritised / addressed.

I did a quick check myself and can see the issue too.
(Assignee)

Comment 6

4 years ago
Hi Michael, Thanks a lot.
We stay tuned and let us know if we can be in any help during the process. :)

Comment 7

4 years ago
At this stage our client is unwilling to fix the issue, its perceived just too low priority.  The issue will go into the next round of reviews in two weeks, be reviewed by the key decision maker, then we should have a final outcome.

Sorry this is not good news for you - at least at this stage.
(Assignee)

Comment 8

4 years ago
Hi michael, 
thanks for the quick answer, could you tell us which framework do you use for user agent identification? Because the only issue is just the wrong mime-type which is sent on identifying the user agent string for Firefox OS.
Flags: needinfo?(mcliffe)

Comment 9

4 years ago
WURL + mods.  No matter how small the change it needs client approval.
Flags: needinfo?(mcliffe)

Updated

4 years ago
Mentor: kdubost
Whiteboard: [sitewait] [serversniff] [country-uk] [mentor=kdubost] → [sitewait] [serversniff] [country-uk]
(Assignee)

Comment 10

4 years ago
(In reply to michael cliffe from comment #9)
> WURL + mods.  No matter how small the change it needs client approval.

Michael Cliffe, could you tell us if the client approval is tied to the upgrade of WURFL? License fees?
Which version do you currently user?
Flags: needinfo?(mcliffe)
(Assignee)

Comment 11

3 years ago
The issue is still the same and not solved. :/
So I guess no modifications has been done, be update of WURFL or anything else.
(Assignee)

Comment 12

3 years ago
ah no. My bad. This is solved for Android.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
More specifically, this is fixed in Fennec 41+ (likely due to adding the Android version in the UA string).
Flags: needinfo?(mcliffe)
And now there's WAP again :-(
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → NEW
Whiteboard: [sitewait] [serversniff] [country-uk] → [contactready] [serversniff] [country-uk]
Seems like it's back to HTML now:

http --print=hH GET  http://www.nextbuses.mobi/ User-Agent:"$FFA"
GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate
Connection: keep-alive
Host: www.nextbuses.mobi
User-Agent: Mozilla/5.0 (Android 5.0.2; Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

HTTP/1.1 200 OK
Cache-Control: private
Content-Encoding: gzip
Content-Length: 1063
Content-Type: text/html; charset=utf-8
Date: Mon, 14 Dec 2015 20:39:50 GMT
Server: Microsoft-IIS/8.0
Vary: Accept-Encoding
X-AspNet-Version: 2.0.50727
X-AspNetMvc-Version: 2.0
X-Powered-By: ASP.NET
Status: NEW → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.