[Cost Control]Current progress rate in progress bar will be displayed outside.

RESOLVED FIXED in 1.4 S2 (28feb)

Status

Firefox OS
Gaia::Cost Control
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Leo, Assigned: joan)

Tracking

unspecified
1.4 S2 (28feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
1. Title : Current progress rate in progress bar will be displayed outside.
2. Precondition : Set the data limit to 1GB and browse upto 3MB.
3. Tester's Action : Open cost control data widget and check the progress bar.                           
4. Detailed Symptom (ENG.) : Data usage rate is displayed outside the progress bar.(Same issue can be reproduced after data usage limit exceeds)
5. GAIA version : f46757775e07d314913b4a5ae975fa131d1c7c4b
6. Expected : Progress bar should show properly.
7.Reproducibility: Y
1)Frequency Rate : 100%
(Reporter)

Comment 1

5 years ago
Created attachment 713335 [details]
Data widget UI break
(Reporter)

Updated

5 years ago
Flags: needinfo?(salva)
Asking UX for prioritization.
Flags: needinfo?(salva) → needinfo?(marcoc)

Updated

5 years ago
Assignee: nobody → salva

Comment 3

5 years ago
Should be a UX-P1. 
It seems like the basic functionality of the data widget graph is not working.
Flags: needinfo?(marcoc)

Comment 4

5 years ago
Got some more info about this as I was having difficulty re-creating the case.
Seems it is more of just a polish issue - so I would prioritize it as a UX_P2.

Comment 5

5 years ago
I run through this issue with LG and it seems that the problem is reproduced by:

1. reset data usage to 0
2. start browsing
3. open utility tray and note the data usage bar is overflowing the container.

We agree that it's a pretty minor issue, but it should be fixed.
Assignee: salva → nobody
blocking-b2g: --- → 1.4?
Please ask for approval once it is ready.
blocking-b2g: 1.4? → ---
(Assignee)

Comment 7

4 years ago
Created attachment 8377464 [details] [review]
Patch on GitHub

Add rule for fix it
Attachment #8377464 - Flags: review?(arnau)
Comment on attachment 8377464 [details] [review]
Patch on GitHub

Awesome! Thanks Joan.
Attachment #8377464 - Flags: review?(arnau) → review+
Assignee: nobody → joan.leon
Merged: e1f8ebe3cbe27923f0070bc13fc059b55749a9f1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
blocking-b2g: --- → 1.3?
(Assignee)

Comment 10

4 years ago
Comment on attachment 8377464 [details] [review]
Patch on GitHub

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): missing property
[User impact] if declined: not matching UI specs
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]:
Attachment #8377464 - Flags: approval-gaia-v1.3?
(Assignee)

Updated

4 years ago
Attachment #8377464 - Flags: approval-gaia-v1.3? → approval-gaia-v1.3?(fabrice)
HI,

This is not a blocker and hence will not be taking for 1.3
blocking-b2g: 1.3? → -
Comment on attachment 8377464 [details] [review]
Patch on GitHub

clearing approval since it's not a blocker.
Attachment #8377464 - Flags: approval-gaia-v1.3?(fabrice)

Updated

4 years ago
Target Milestone: --- → 1.4 S2 (28feb)
You need to log in before you can comment on or make changes to this bug.