[Contacts] The "sort by last name" switcher is not initialised correctly

RESOLVED FIXED

Status

Firefox OS
Gaia::Contacts
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: alberto.pastor, Assigned: crdlc)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:

1.- Open Contacts app
2.- Go to Settings
3.- Enable "order by last name"
4.- Kill the app
5.- Repeat the process and check the switcher

Expected:
The switcher is enabled

Actual:
The switcher is disabled
(Reporter)

Updated

5 years ago
blocking-b2g: --- → tef?

Comment 1

5 years ago
We'd block on broken functionality, but not broken reported status. Adding qawanted to verify which it is (setting doesn't work, or setting doesn't display properly).
Keywords: qawanted

Comment 2

5 years ago
I just tested this; STR in comment 0 holds true if only if you kill the contacts app.  Otherwise the last name switcher works as expected as long as contacts app is open.

But I agree this should be tef+'d, because its easy to force kill the contacts app.  Once that app is restarted, the setting does not persist.  This will mess up people's expected contacts configuration, so i nominate it to block and fix for this release.

Tested on:
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/d1288313218e
Gaia   6544fdb8dddc56f1aefe94482402488c89eeec49
BuildID 20130214070203
Version 18.0
Keywords: qawanted
The setting is persisted, it's just the reporting of it that is incorrect. My contacts are still sorted by last name when I re-launch the app, but if I go into settings the toggle is in the wrong position.

If you want to return to sort by first name then you have to hit the toggle twice, which is annoying but not something I'd block on.
(Assignee)

Updated

5 years ago
Assignee: nobody → crdlc
(Assignee)

Comment 4

5 years ago
Created attachment 715068 [details]
Patch v1
Attachment #715068 - Flags: review?(jmcf)

Updated

5 years ago
Attachment #715068 - Flags: review?(jmcf) → review+

Comment 5

5 years ago
https://github.com/mozilla-b2g/gaia/commit/fddf445e09d92a8acc5c445e4e189bfe87fe0cb6
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 6

5 years ago
Comment on attachment 715068 [details]
Patch v1

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Contact settings latest improvements left this check outdated
User impact if declined: very high
Testing completed: yes
Risk to taking this patch (and alternatives if risky): Very low risk. Alternative is a mal-functioning app. this should be blocking, we believe.
Attachment #715068 - Flags: approval-gaia-v1?
Attachment #715068 - Flags: approval-gaia-v1?
Removing the approval-gaia-v1 request. This bug should be marked as tef+ (agree with Tony) and should be landed therefore in v1.0.1
I don't care if it is tef+ or not, but this should land from TElefonica perspective in 1.0.1
blocking-b2g: tef? → -
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → affected
tracking-b2g18: --- → +
Comment on attachment 715068 [details]
Patch v1

[Triage Comment]
Approving for uplift, as it is a reporting issue and not a functionality issue this is not a blocker but we can uplift this low risk fix for v1.0.1
Attachment #715068 - Flags: approval-mozilla-b2g18+
v1-train@87d08b8
v1.0.1@3d463e9
status-b2g18: affected → fixed
status-b2g18-v1.0.1: affected → fixed
You need to log in before you can comment on or make changes to this bug.