Closed Bug 841497 Opened 7 years ago Closed 7 years ago

file installed xpis, console.log doesn't work.

Categories

(Add-on SDK Graveyard :: General, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: glind, Unassigned)

Details

https://github.com/ilanasegall/ctp-micropilot/blob/master/lib/main.js#L4 for an example.

If you cfx run, it's fine.  Install from xpi, not so much.
No longer depends on: 731074
"It's actually a feature, not a bug" (and for the first time for me, it's actually true…):

https://github.com/mozilla/addon-sdk/commit/29ba77a55414d645daf015ae6d7c7da5155976c8

So basically the default log level for developers is `info`, but for users (when the add-on is installed) is `error`, so `console.log` won't be bothered the user, unless the add-on change its log level prefs (`"extensions." + self.id + ".sdk.console.logLevel"`).

Say that, as far as I know it's not documented anywhere, and it should. So I will close that bug, and open a new Documentation bug.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.