Project Kickoff Form: New Finance Option for Vendor Cost

RESOLVED DUPLICATE of bug 912793

Status

()

RESOLVED DUPLICATE of bug 912793
6 years ago
5 years ago

People

(Reporter: mcoates, Assigned: dkl)

Tracking

Production

Details

(Whiteboard: [v1.1])

We're simplifying the form for the Vendor cost question (#14d). This involves two changes:

Change 1
Eliminate #14d1 - This question is only displayed if <=$25,000 is selected for question #14d

Change 2
Update question #14d with an additional option in the drop down titled:
<$25,000 - Vender Requests PO
This means there will no be 4 options in the dropdown:
N/A
<=$25,000
<$25,000 - Vender Requests PO
>$25,000

If a user selects >$25,000 OR <$25,000 - Vender Requests PO
then the Finance Questions should be displayed

This updated flow is reflected in version 1.1 of the logic flow chart
(Assignee)

Comment 1

5 years ago
Updated test instance for your verification:

https://bugzilla-dev.allizom.org/form.moz.project.review

dkl
Assignee: nobody → dkl
Status: NEW → ASSIGNED
Flags: needinfo?(mcoates)
I typoed the request. We should have an equal sign in both cases.

N/A
<=$25,000
<=$25,000 - Vender Requests PO
>$25,000
Flags: needinfo?(mcoates)
I noticed that if you select hardware purchase for type of relationship then the finance questions are displayed regardless of the vendor cost.

Winnie - Can you confirm this is desired behavior?

I verified that in other cases (e.g. type of relationship is vendor/services) the finance questions are correctly displayed for >25,000 or <=$25,000 - Vender Requests PO
Flags: needinfo?(waoieong)
Confirmed that it should be the same as other type of relationship, it should still have the four options for vendor cost. Please revise.
Flags: needinfo?(waoieong)
I chatted with Winnie. It looks like we have a small bug here to resolve. Currently if you select "hardware purchase" for type of vendor then the finance questions are displayed regardless of what vendor cost is selected. This is incorrect.

The behavior when selecting "vendor/services" is the desired behavior. In other words, the finance questions should be displayed based upon the answer to the vendor cost question only.
(Assignee)

Comment 6

5 years ago
(In reply to Michael Coates [:mcoates] from comment #5)
> I chatted with Winnie. It looks like we have a small bug here to resolve.
> Currently if you select "hardware purchase" for type of vendor then the
> finance questions are displayed regardless of what vendor cost is selected.
> This is incorrect.
> 
> The behavior when selecting "vendor/services" is the desired behavior. In
> other words, the finance questions should be displayed based upon the answer
> to the vendor cost question only.

Sorry for the delay in addressing this issue. Can you verify the above please as the Kickoff form flowchart I have currently has an arrow going from "Hardware Purchase" to "Finance Questions" which means according to it, the finance questions should come up. I can definitely make it where they do not display if it is undesired but we will need to update the flowchart as well.

dkl
Flags: needinfo?(mcoates)
Winnie will own kickoff form now.
Flags: needinfo?(mcoates) → needinfo?(waoieong)
(Assignee)

Comment 8

5 years ago
This bugs seems to overlap with 912793 in the requirements. Can we dupe this one and work on this as a single request?
(In reply to David Lawrence [:dkl] from comment #8)
> This bugs seems to overlap with 912793 in the requirements. Can we dupe this
> one and work on this as a single request?

Sure, I have no problem with that. Whichever is best for you guys.
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 912793
Answer this in bug 912793
Flags: needinfo?(waoieong)
You need to log in before you can comment on or make changes to this bug.