The perf/integration tests should throw a better error when an app is not found on the device

RESOLVED FIXED

Status

Firefox OS
Gaia::PerformanceTest
P5
normal
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: julienw, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [c=automation p= s= u=])

(Reporter)

Description

5 years ago
Right now, we get this error :

TypeError: app is null

This is not so nice, I'd prefer to have a nice error instead.
(Reporter)

Updated

5 years ago
Duplicate of this bug: 843065

Updated

5 years ago
Keywords: perf
Whiteboard: [c=instrumentation p=]

Updated

5 years ago
Whiteboard: [c=instrumentation p=] → [c=automation p= s= u=]

Updated

5 years ago
Priority: -- → P5

Updated

4 years ago
Component: Gaia → Gaia::PerformanceTest

Comment 2

3 years ago
This is resolved in Raptor:

https://github.com/mozilla-b2g/raptor/blob/master/lib/suite/cold-launch.js#L179
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.