Last Comment Bug 841752 - high cpu consumption & lag while firefox is running on second monitor. HWA setting has no impact
: high cpu consumption & lag while firefox is running on second monitor. HWA se...
Status: RESOLVED WORKSFORME
: perf
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: 18 Branch
: All Windows 7
: -- normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-15 07:45 PST by [:philipp]
Modified: 2016-01-11 03:55 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description [:philipp] 2013-02-15 07:45:08 PST
several windows users in the support forums have reported that firefox is becoming slow, using high cpu ressources & mouse movements are generally laggy when the firefox window is running on an external dvi/hdmi-connected monitor in a dual-screen setup. 
this seems to have started with the firefox 18 release & apparently isn't related to hardware acceleration, since it's also happening in safemode/with HWA disabled and reportedly with gpus from different vendors.

https://support.mozilla.org/en-US/questions/946567
https://support.mozilla.org/en-US/questions/950465
https://support.mozilla.org/en-US/questions/939759#answer-397638
Comment 1 aebirner 2013-02-17 12:38:50 PST
I'm one of those several users.  For me, safemode DOES prevent the problem.  However, manually disabling all addins or turning off HWA in firefox or even disabling all accelerations in the display driver DOES NOT prevent the problem. Idle CPU utilization for firefox on my machine usually sits at about 2.5-3.5% (according to ProcessExplorer); I find that I can drive it up to 20-25% by moving the mouse pointer quickly across links or menu items that need to change appearance upon mouseover--but only if the window is open on the second monitor (which I believe is VGA connected).  In safemode, by way of contrast, CPU utilization is a fairly constant 8-9%.  The net effect is that for me, firefox is unusable on the second monitor.
Comment 2 Loic 2013-02-18 07:37:27 PST
aebirner, could you use the tool mozregression (see http://harthur.github.com/mozregression/ to use it) to find a possible regression range since FF17 or FF18?
(ex: mozregression --good=2012-08-01)

It would be useful to find a regression.
Comment 3 aebirner 2013-02-18 20:04:54 PST
Hmmm.  All of the nightly builds worked just fine.  I had trouble getting CPU utilization above 5%.  What should I try next?  Disabling all extensions and plugins one by one?
Comment 4 Loic 2013-02-19 01:29:24 PST
You can start by testing with a fresh profile with FF18 (see https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles)
Comment 5 dragonq0105 2013-02-19 03:56:38 PST
Using a fresh profile doesn't fix the problem for me.
Comment 6 dragonq0105 2013-02-20 03:35:21 PST
I tried mozregression and I get the same problem with nightly builds at least as old as 2010-01-01. :(
Comment 7 Loic 2013-02-20 03:37:11 PST
dragonq0105, did you test with HWA disabled?
(see http://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration)
Comment 8 dragonq0105 2013-02-20 03:48:11 PST
The nightly build from 2010-01-01 doesn't have hardware acceleration as far as I can tell.

Something very interesting: if I have Chrome open at the same time as having Firefox open, the Firefox mouse slowness completely disappears (in both 2010-01-01 and 18.0.2)!
Comment 9 aebirner 2013-02-20 18:55:01 PST
From the "I hate when that happens" dept:  No longer able to reproduce, as of FF19 release.
Comment 10 aebirner 2013-02-20 18:58:25 PST
That said, scrolling is still noticeably slower/jerkier on the second (VGA-attached) monitor than on the built-in LCD panel.  The mouse stickiness is gone, though.  I'm back to using Firefox on my big monitor, again.
Comment 11 Loic 2013-02-21 00:43:41 PST
aebirner, do you know if previous versions (FF15-16-17 or lower) got this issue about scrolling jerky on the 2nd monitor?
If it was fine in the past, can you file a new bug report and use mozregression tool (see http://harthur.github.com/mozregression/) to find a regression range, please.
Comment 12 dragonq0105 2013-02-22 02:42:12 PST
Firefox 19 doesn't fix the issue for me. I still need Chrome open (even minimised) to eliminate the jerky mouse movement.
Comment 13 Loic 2013-02-22 02:50:44 PST
Be sure your drivers are up-to-date.
Comment 14 dragonq0105 2013-02-22 02:53:09 PST
I can't think of any other drivers to check. Chipset, mouse and graphics drivers are all the latest available.
Comment 15 aebirner 2013-03-05 09:21:45 PST
(In reply to Loic from comment #11)
> aebirner, do you know if previous versions (FF15-16-17 or lower) got this
> issue about scrolling jerky on the 2nd monitor?
> If it was fine in the past, can you file a new bug report and use
> mozregression tool (see http://harthur.github.com/mozregression/) to find a
> regression range, please.

No previous versions of FF had this problem.  Both issues (mouse stickiness, slow scrolling) first appeared in FF 18; the mouse stickiness disappeared for the most part in FF 19, but the scrolling issue remains.  There now seems to be a general slowness to the initial rendering of a page on the second monitor; scrolling and mouse movements are noticeably jerky while the page is rendering, but much less so after the page is initially displayed.  I will file a new bug report for these latter issues.
Comment 16 eamon 2013-03-18 06:58:06 PDT
I'm also having this issue, and it's happening on a desktop.  I think I might have an idea as to the cause.

First of all however: I'm running in safe mode with HWA off with the latest nightly (22.0a1 (2013-03-14)), and the problem still occurs.

I've got two graphics cards: an i7 2600k's built-in intel HD3000, and an nvidia 7600GT. 

The problem only occurs on the two monitors attached to the second GFX adadapter (nvidia 7600gt).

Could it be that the people with laptops that are seeing this have one of those dual-mode GFX laptop setups with both an onbord and add-on GFX card?  Those aren't uncommon for power saving / performance tradeoff reasons.
Comment 17 dragonq0105 2013-03-18 07:32:19 PDT
Nice idea but my laptop, which still suffers from this issue, doesn't have a second GPU. It only has the IGP on the i5-430m, with the external monitor connected via HDMI.
Comment 18 Brandon Shea 2013-04-11 10:03:18 PDT
I can confirm this issue in the latest Firefox 21 beta. I'm running on Windows 8 64-bit with two video cards (Intel graphics and Geforce 8400GS). When Firefox is running on the monitor powered by Intel graphics, everything is perfectly smooth. If Firefox moves to one of the monitors on the Geforce 8400GS, the mouse movement is very jerky.

Let me know if there's any additional information I can provide.
Comment 19 aebirner 2013-05-17 20:09:08 PDT
This is still a problem for me with FF 21 on WinXP SP3.  I first uninstalled FF, removed the various installation and profile directories, and deleted all the registry keys that I could find; then I reinstalled from a fresh download.  Still the same effect on my dual-monitor setup:  Performance is great when the browser window is on the laptop LCD, but is slow as molasses in January when the window is open on the VGA-attached second monitor.  Disabling hardware acceleration has no effect.
Comment 20 aebirner 2013-05-19 15:04:21 PDT
My computer is a Lenovo T420s.  The device manager says the display is an "Intel(R) HD Graphics Family".  The driver is version 6.1.10.5361, dated 5/2/2011.  Monitor 1 is the laptop LCD, which is set to 1600x900 pixels w/ 32-bit color  (and on which I see no performance problems).  Monitor 2 is an external VGA-connected LCD, set to 1680x1050 at 60 Hz, also w/ 32-bit color.  I have also duplicated the problem when using a Samsung T240HD at 1920x1200 as Monitor 2.
Comment 21 Wayne Mery (:wsmwk, NI for questions) 2016-01-06 21:43:45 PST
Almost 3 years later, do you still see this problem?
Comment 22 eamon 2016-01-07 01:23:21 PST
The machine with the iGFX and discrete GFX card that used to exhibit this problem for me has been retired, so I can't tell whether this problem still exists.
Comment 23 Brandon Shea 2016-01-07 03:48:20 PST
I haven't seen this bug in a long time, nor do I have the original computer I reported the issue on.
Comment 24 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2016-01-07 11:47:53 PST
Closing this bug based on the above two comments. If anyone can reproduce this in a current Firefox version, please reopen and update the information in this bug report. Thanks.

Note You need to log in before you can comment on or make changes to this bug.