Closed Bug 841962 Opened 10 years ago Closed 10 years ago

[B2G][OTA] Update channel change makes bootup significantly slower

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:-)

RESOLVED DUPLICATE of bug 842932
blocking-b2g -

People

(Reporter: dhylands, Assigned: dhylands)

References

Details

(Keywords: smoketest)

+++ This bug was initially created as a clone of Bug #841041 +++

For this test I was using gaia v1-train and mozilla-inbound just after the patch from 841041 landed.

1 - Flash built image

2 - Create an update (to the same version)
    ./build.sh gecko-update-full

3 - Setup the phone to use the update
    tools/update-tools/test-update.py ${GECKO_OBJDIR}/dist/b2g-update/b2g-gecko-update.mar

4 - Do a Check Now and then do the update

Time from the pressing Install Now until the "based on mozilla technology" splash is about 15 seconds, and about 3 seconds after that the unlock screen appears.

If you change the Update channel

5 - Modify gecko/toolkit/content/UpdateChannel.sh near the end to override the channel:

    channel = "foobar";
    return channel;

6 - rebuild

7 - Do steps 2 thru 4

The time from pressing Install Now until "based on mozilla technology" splash is about 90 seconds.

Once the unlock screen does appear, then the phone appears to be fine (i.e. performance seems similar to before).
If I comment out the:

prefSvc.observe(null, "reload-default-prefs", null);

https://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/update/nsUpdateService.js#2803

then the boot time goes back to normal.
I'm putting this to tef? (it was tef+ since it was cloned) so it goes through triage.
blocking-b2g: tef+ → tef?
Depends on: 842932
Once bug 842932 gets fixed, then the bootup goes back to normal speeds.
see bug 842932 comment 5
blocking-b2g: tef? → -
Closing this as a dup of bug 842932 since it seems to be fixed by that bug.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 842932
You need to log in before you can comment on or make changes to this bug.