Updater removes command line option after update

VERIFIED FIXED

Status

()

Toolkit
Application Update
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

21 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox21+ verified)

Details

(Reporter)

Description

5 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/7bd555e2acfa
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130216 Firefox/21.0 ID:20130216031127

The problem happens when update Nightly from 2013-02-15 to 2013-02-16.

Steps To Reproduce:
1. Download 2013-02-15 Nightly from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-02-15-03-10-40-mozilla-central/firefox-21.0a1.en-US.win32.installer.exe
2. And Install with default setting
3. Exit Nightly

4. Edit properties Nightly shortcut in Start menu
   Append -P profile (e.g, "C:\Program Files (x86)\Nightly\firefox.exe" -P profile )

5. Start Nightly
6. Upate and Restart to Update
7. Exit Nightly

8. Confirm properties Nightly shortcut in Start menu

Actual Results:
  missing  -P profile.

Expected Result:
  Updater should not change command line option
(Reporter)

Updated

5 years ago
Keywords: regression
Probably due to bug 841197
Blocks: 841197
No need for a regression range, thanks.
Can we resolve this before Wednesday night's (Thursday morning's) build? I am guessing users updating to latest aurora and using command line options will be affected here. Correct ?

I am ccing QA to help verify this as a part of 21.0a2 sign-off .
Keywords: qawanted, verifyme
I think a fix for this landed in bug 841197. Kamil is going to verify it with tomorrow's build while he is testing bug 841197.  If it passes I told him to mark this as resolved / works for me.
(Reporter)

Comment 5

5 years ago
It seems fixed in Nightly2013-02-20.
http://hg.mozilla.org/mozilla-central/rev/401b967b2dfc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130220 Firefox/22.0 ID:20130220031126
Went through the following issue and everything passed without any problems.

Downloaded and installed the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-02-08-03-10-53-mozilla-central/firefox-21.0a1.en-US.win32.installer.exe

Once the above build has been installed, went through the following steps:

- Selected "Start -> All Programs"
- Right clicked on "Nightly" and changed the "Target" to the following value: "C:\Program Files (x86)\Nightly\firefox.exe" -ProfileManager
- Launched the Nightly build and ensured that the Profile Manager is launched
- Updated the Nightly build using the "Help -> About Nightly" (22.0a1 2013-02-20)
- Once updated, closed the Nightly build and re-opened it (Profile Manager was launched)
- Checked the "Nightly Properties" once again and ensured that the value was: "C:\Program Files (x86)\Nightly\firefox.exe" -ProfileManager
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
status-firefox21: --- → fixed
tracking-firefox21: ? → +
Calling this verified fixed based on comment 4, 5, and 6.
Status: RESOLVED → VERIFIED
status-firefox21: fixed → verified
Keywords: qawanted, verifyme
Resolution: WORKSFORME → FIXED
This changeset landed in bug 841197, but putting it here also since we're marking this as fixed:
https://hg.mozilla.org/mozilla-central/rev/71e84eb9db9f
You need to log in before you can comment on or make changes to this bug.