tried to Quit, Crashed instead

VERIFIED DUPLICATE of bug 84351

Status

MailNews Core
Backend
VERIFIED DUPLICATE of bug 84351
17 years ago
7 years ago

People

(Reporter: Mitch Green, Assigned: Scott MacGregor)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9+) Gecko/ Netscape6/6.1b1
BuildID:    2001060504

Selected "File | Quit" and crashed.

Reproducible: Didn't try
Steps to Reproduce:
1. Quit
2.
3.

Actual Results:  Crash

Expected Results:  Quit

Entered Talk Back report.  Will attach a MacsBug dump.
(Reporter)

Comment 1

17 years ago
Created attachment 37312 [details]
macsbug dump
(Reporter)

Comment 2

17 years ago
Was able to duplicate on my second attempt to Quit.  Another MacsBug dump is
attached.
(Reporter)

Comment 3

17 years ago
Created attachment 37313 [details]
macsbug dump (of second attempt to Quit)
(Reporter)

Comment 4

17 years ago
Both times of tried to Quit this build, it's crashed instead.  If it crashes
upon exit again, I'm not going to append to this bug, but will submit a talk
back report.
(Reporter)

Comment 5

17 years ago
Happened again with Build 2001060608. Attaching MacsBug dump (Quit.Crash.3.macsbug).
(Reporter)

Comment 6

17 years ago
Created attachment 37429 [details]
macsbug dump
(Reporter)

Comment 7

17 years ago
This happens about 33% of the time I try to Quit the app on Mac OS 9.1.  Are
more MacsBug dumps and Talk Back reports helpful?  Or should I stop submitting?
 I appear to be the only person paying attention to this bug.  It's a CRASH!!!!
(Reporter)

Comment 8

17 years ago
And BTW, I get a new build one or more times per day.  The most recent crash
happened in build #2001060708 (Netscape-branded client).

Comment 9

17 years ago
2001-06-07-11-0.9.1 Macos build

workw for me.

Comment 10

17 years ago
Looks like all 3 of the posted macsbug reports end in
nsServiceManagerImpl::ReleaseService.  A quick scan of XPCOM crasher bugs fails
to turn this up. Inspection further up the stack shows a fair amount of Mail
stuff.  Were you Quitting the app from mail? Was the browser even open?  Had you
checked mail? Read mail? Sent Mail? Do you have new or migrated mail Filters? 
Can you please post exact steps you take when you see this crash
<http://www.mozilla.org/quality/bug-writing-guidelines.html>.  Thanks.

Worksforme with 061104 mozilla win32 build on win2K and win98, 061108 mozilla
linux build on RedHat 6.2 and 061108 mozilla mac build on OS 8.5 and 9.1 

I tried shutdown on the 2 macs about 20 times each and tried a combined 10 times
on win32 and linux builds.  I tested by starting the browser, letting it load
the start page, launching mail, checking for new messages and then
File|Quit/Exit. I tested about half of the time with Clean 0.9.1 profiles and
half of the time with migrated 4.7 profiles.  The 4.x profiles do not have any
message filters but the 0.9.1 profiles do.  All tests from profiles with at
least 1 IMAP mail server set up.

Without clear steps to reproduce and from the activity in the macsbug logs
guessing and sending to MailNews

--Asa 
Assignee: asa → mscott
Component: Browser-General → Mail Back End
Product: Browser → MailNews
QA Contact: doronr → esther
(Assignee)

Comment 11

17 years ago
This looks like a top crasher bug I filed last week. It's on the trunk only and
was fixed on 06/07/01. Please use a build from 06/08 or later and let us know if
you still see the problem.

Marking as a dup. 

*** This bug has been marked as a duplicate of 84351 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
QA Contact: esther → laurel

Comment 12

17 years ago
Marking verified as a duplicate.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.