B2G Emulator: clean up calls from previous marionette tests

RESOLVED DUPLICATE of bug 811167

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 811167
5 years ago
5 years ago

People

(Reporter: hsinyi, Assigned: hsinyi)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
Telephony calls exist from previous marionette tests make marionette tests fail in checking "emulator gsm-list" initial state. Let's clean up those calls completely in emulator.
(Assignee)

Updated

5 years ago
Blocks: 838047
(Assignee)

Updated

5 years ago
Assignee: nobody → htsai
(Assignee)

Comment 1

5 years ago
I am going to add 'gsm clear' console command to clean up all the current calls. And to revise the marionette tests a little bit by using 'gsm clear' to have a clean initialization state before a test does real work.
(Assignee)

Comment 2

5 years ago
Created attachment 715856 [details]
Pull request - emulator change

add 'gsm clear' console command
Attachment #715856 - Flags: review?(vyang)
(Assignee)

Comment 3

5 years ago
Created attachment 715857 [details] [diff] [review]
marionette tests modification

using 'gsm clear' to have a clean initialization state
Attachment #715857 - Flags: review?(vyang)
Comment on attachment 715856 [details]
Pull request - emulator change

Merged on github :)
Attachment #715856 - Flags: review?(vyang) → review+
Comment on attachment 715857 [details] [diff] [review]
marionette tests modification

Review of attachment 715857 [details] [diff] [review]:
-----------------------------------------------------------------

Great job!
Attachment #715857 - Flags: review?(vyang) → review+
(Assignee)

Updated

5 years ago
Depends on: 843943
Emulator has been updated.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 851406
Whoops, duped wrong bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 811167
You need to log in before you can comment on or make changes to this bug.