Closed Bug 842531 Opened 8 years ago Closed 8 years ago

Need to be able to target real events at RTCPeerConnection

Categories

(Core :: WebRTC: Signaling, defect, P1)

21 Branch
x86
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 823512

People

(Reporter: abr, Assigned: abr)

References

Details

(Whiteboard: [WebRTC] [blocking-webrtc-] [spec-issue] [parity-chrome])

Attachments

(1 file, 1 obsolete file)

Currently, PeerConnection.js does not implement the ongatheringchange event to signal that all local candidates have been gathered.
Correction -- apparently, we do call ongatheringchange. But since we don't do trickle ICE (see Bug 842549), we call it before the createOffer or createAnswer happens.

Apparently, this surprises some applications.

Our stopgap solution is to emit these event immediately upon success of createOffer and createAnswer rather than when the ICE stack actually completes these actions. These stopgaps will need to be removed once trickle ICE is done.
Summary: Peer connection never calls ongatheringchange → Peer connection calls ongatheringchange in a way that startles some scripts
Attachment #715495 - Flags: review?(ekr)
Attachment #715495 - Attachment is obsolete: true
Attachment #715495 - Flags: review?(ekr)
Comment on attachment 715511 [details] [diff] [review]
Emit ice changes only after createOffer/createAnswer

Review of attachment 715511 [details] [diff] [review]:
-----------------------------------------------------------------

seems good enough fornow.
Attachment #715511 - Flags: review+
This rabbit hole got very deep very fast.

The big issue is that we presently call the ongatheringchange callback with a string rather than an Event. To handle this correctly, we need to make PeerConnection an nsIEventTarget. However, PeerConnection is currently implemented in javascript, which precludes it from being an event target (see bug 731746).
Depends on: 731746, 823512
Summary: Peer connection calls ongatheringchange in a way that startles some scripts → Need to be able to target real events at RTCPeerConnection
Priority: -- → P1
Whiteboard: [WebRTC] [blocking-webrtc-] → [WebRTC] [blocking-webrtc-] [spec-issue] [parity-chrome]
This issue is being fixed as part of the change from IDL to WebIDL; see Bug 823512.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 823512
You need to log in before you can comment on or make changes to this bug.