Closed Bug 842577 Opened 7 years ago Closed 7 years ago

Remove from History is visible for a paused download

Categories

(Firefox :: Downloads Panel, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 22
Tracking Status
firefox19 --- unaffected
firefox20 --- verified
firefox21 --- verified

People

(Reporter: simona.marcu, Assigned: mak)

Details

Attachments

(1 file)

Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20130218 Firefox/21.0
Build ID: 20130218031106

Steps to reproduce:
1. Launch Firefox
2. Navigate to http://www.mozilla.org/en-US/products/download.html?product=firefox-18.0.2&os=win&lang=en-US and download the latest Firefox version
3. Open the Panel -> right click on the download in progress -> select Pause.
4. In the Panel -> right click again on the paused download
5. Open the Downloads View -> right click on the paused download and look over the options from the context menu

Expected results:
The options from the context menu are the same in the panel and in the downloads view:
Resume
Cancel
Remove From History
Open Containing Folder
Go to Download Page
Copy Download Link
Clear List/Clear Downloads

Actual results:
In the Downloads View - Remove from History option is missing when the download is paused.
 
Note:
- reproducible on the latest Nightly
- reproducible on the latest Aurora:
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20130218 Firefox/20.0 (20130218042018)
- issue is reproducible ever since December 18th:
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c8a1314aa449&tochange=2e70b718903a
the problem looks like being the fact the panel uses downloadRemoveFromListMenuItem class while the rule is on downloadRemoveFromHistoryMenuItem

So the Library seems to be right.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Summary: Remove from History is missing for a paused download → Remove from History is visible for a paused download
Attached patch patch v1.0Splinter Review
quite trivial patch
Attachment #715536 - Flags: review?(mconley)
Comment on attachment 715536 [details] [diff] [review]
patch v1.0

Good catch! Looks like I missed this one in bug 817006. Thanks. :)
Attachment #715536 - Flags: review?(mconley) → review+
Comment on attachment 715536 [details] [diff] [review]
patch v1.0

[Approval Request Comment]
Bug caused by (feature/regressing bug #): downloads panel / bug 817006
User impact if declined: the downloads panel shows "Remove From History" option at the wrong time, the options may not work as expected when this happens
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): trivial oneliner, it's just fixing a missed class change in bug 817006
String or UUID changes made by this patch: none
Attachment #715536 - Flags: approval-mozilla-beta?
Attachment #715536 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/1b1b5e236817
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 715536 [details] [diff] [review]
patch v1.0

Approving as this is low risk. We may back out if need be in case of any new regressions this may cause on beta.
Attachment #715536 - Flags: approval-mozilla-beta?
Attachment #715536 - Flags: approval-mozilla-beta+
Attachment #715536 - Flags: approval-mozilla-aurora?
Attachment #715536 - Flags: approval-mozilla-aurora+
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0

Verified the fix on Firefox 20.0 beta 2: "Remove from History" option is not available in the Downloads Panel nor in the Downloads View in the Library window.
Verified as fixed on Windows 7 64bit, Ubuntu 12.10 32bit and Mac OSX 10.7.5 with Firefox 21 beta 3 (20130416200523).
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.