plugin click-to-play play button has default cursor

VERIFIED FIXED in Firefox 21

Status

()

defect
P2
minor
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: c.ascheberg, Assigned: c.ascheberg)

Tracking

21 Branch
mozilla22
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox21 verified, firefox22 verified)

Details

(Whiteboard: [CtpDefault:P2])

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
The play icon of the plugin click-to-play UI |:-moz-handler-clicktoplay .icon| on hover shows the default cursor. It should show the pointer cursor.

Comment 1

6 years ago
Dammit. Apparently <html:button> has a default style rule of cursor: default so we need to override that with everything else.
Assignee: nobody → benjamin
Priority: -- → P2
Whiteboard: [CtpDefault:P2]
(Assignee)

Comment 2

6 years ago
This seems to work
Attachment #716213 - Flags: review?(jAwS)

Comment 3

6 years ago
Thanks for taking this.
Assignee: benjamin → c.ascheberg
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/31daf94fb0a4
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
Version: Trunk → 21 Branch
Comment on attachment 716213 [details] [diff] [review]
possible patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 831921
User impact if declined: mouse cursor will not be a hand (pointer) on the play button, fx21 is first release for new CTP ui.
Testing completed (on m-c, etc.): locally and landed on m-c
Risk to taking this patch (and alternatives if risky): none expected
String or UUID changes made by this patch: none
Attachment #716213 - Flags: approval-mozilla-aurora?
Attachment #716213 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flagging for verification against Firefox 21 and 22.
Keywords: verifyme
This is still happening for the X button. Any thoughts?
(Assignee)

Comment 10

6 years ago
(In reply to Paul Silaghi [QA] from comment #9)
> This is still happening for the X button. Any thoughts?

According to bug 831921 comment 20 this is intended. I'd say it does make sense as the performed action is different from the rest of the UI.
Based on comment 10 verified fixed on FF 21.0a2 (2013-03-17), 22.0a1 (2013-03-17) Win 7, Ubuntu 12.04 and Mac OS X 10.7.5
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.