Last Comment Bug 84271 - Fizzilla defaults to old CJK fonts (Osaka instead of Hiragino Pro)
: Fizzilla defaults to old CJK fonts (Osaka instead of Hiragino Pro)
Status: RESOLVED WORKSFORME
: intl
Product: Core Graveyard
Classification: Graveyard
Component: GFX: Mac (show other bugs)
: Trunk
: PowerPC Mac OS X
: P4 enhancement (vote)
: Future
Assigned To: Simon Fraser
:
Mentors:
Depends on:
Blocks: 103669
  Show dependency treegraph
 
Reported: 2001-06-06 00:53 PDT by Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01)
Modified: 2009-01-22 10:17 PST (History)
13 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screen shot Netscape JA home page with "Osaka" set as Japanese font. (49.86 KB, image/jpeg)
2002-03-12 15:07 PST, nhottanscp
no flags Details
Screen shot Netscape JA home page with "Hiragino Mincho Pro W3" set as Japanese font. (48.09 KB, image/jpeg)
2002-03-12 15:08 PST, nhottanscp
no flags Details
Screen shot Netscape JA home page with "Hiragino Kaku Gothic Pro W3" set as Japanese font. (48.65 KB, image/jpeg)
2002-03-12 15:10 PST, nhottanscp
no flags Details
Gecko charsets/locales styled with CSS fonts (8.14 KB, text/html)
2004-12-06 14:52 PST, Smokey Ardisson (offline for a while; not following bugs - do not email)
no flags Details
Gecko charsets/locales styled with CSS fonts (revised/corrected by jshin) (8.65 KB, text/html)
2005-03-13 23:42 PST, Smokey Ardisson (offline for a while; not following bugs - do not email)
no flags Details

Description Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2001-06-06 00:53:21 PDT
Build ID: 2001-06-05 FizzillaCFM

Steps to reproduce:
1) Create a new profile if necessary
2) Take a look at the East Asian font prefs

Actual results:
Fizzilla defaults to Mac OS 8.x/9.x era fonts.

Expected results:
Expected Fizzilla to default to the new fonts that Apple is shipping with Mac OS
X when it makes sense to use the new fonts.

For example, in the Japanese prefs Osaka is the default for serif, sans-serif
and cursive. It might be better to use Hiragino Mincho Pro W3 for serif &
cursive and to use Hiragino Kaku Gothic Pro W3 for sans-serif.

Disclaimer: I can't actually read these languages, so there is a chance I am
missing the point.
Comment 1 Frank Tang 2001-06-11 10:24:09 PDT
OSX related bug. Reassign to nhotta. 
We need more study about this before do anything. 
Keep this bug as no target for now. 
Comment 2 Frank Tang 2001-06-19 02:01:03 PDT
mark as moz0.9.3
Comment 3 Frank Tang 2001-08-21 17:19:16 PDT
move to m94 and ftang
Comment 4 Hong Kwon 2001-08-29 13:16:17 PDT
Is the 0.9.4 milestone realistic?  We are branching on Friday.
Comment 5 Frank Tang 2001-08-30 17:29:01 PDT
no, move to 95
Comment 6 Frank Tang 2001-08-31 13:04:30 PDT
P4.
Comment 7 Frank Tang 2001-10-08 10:13:29 PDT
dear nhotta- can you do some research on this ?
I know pierre once try to put the multiple default font name fallback ont omac 
from our window code which shanjian wrote, I am not sure it's done or not. maybe 
we can use that facility for this. 

cc pierre
Comment 8 Pierre Saslawsky 2001-10-08 16:40:37 PDT
Multiple default fonts are decribed under bug 71539 which covers the 
implementation on the Mac of bug 61883.
Comment 9 Frank Tang 2001-10-29 11:56:13 PST
reassign back to ftang:
got answer from xavier@apple.com

Frank,

Here are the answers to the font questions you asked me:
For Japanese it would be: "ƒqƒ‰ƒMƒm–¾’© Pro W3", "ƒqƒ‰ƒMƒmŠpƒS Pro W3",
"Osaka-“™•�", "ƒqƒ‰ƒMƒmŠÛƒS Pro W4", "ƒqƒ‰ƒMƒmŠÛƒS Pro W4". Note, it is much
better if they can use font fallback like the system does, e.g. use Western
set of fonts for Latin characters.

Cyrillic fonts have been renamed to:   "Times CY" "Helvetica CY" "Monaco CY"

Turkish is a Roman variant covered by our Western script fonts.
i.e. Western "Times" "Helvetica" "Courier" "Apple Chancery" "Gadget"
Apple Chancery and Gadget are not shipped on OSX.

For OSX the same fonts are available on the menu or an updated set could be
used.

Don't have info on Baltic but assume same as Turkish if it is latin script.
Which languages does baltic cover?

Your Thai is OK, though we may add/change the fonts for Thai in OSX.

Arabic would be "AB Geeza" "AB AlBayan" "AB Baghdad" "AB Kufi" "AB Nadeem"
Though I'm not certain of the style matches.

Comment 10 Frank Tang 2001-10-29 11:56:59 PST
switch your brwoser to shift jis to see the previous comment
Comment 11 Frank Tang 2001-10-29 12:17:45 PST
to implement this, we probably need a fallback default font mechanism as what we 
have in window.
Comment 12 Pierre Saslawsky 2001-10-29 13:35:18 PST
There is a dependency on bug 71539 already.
Comment 13 Frank Tang 2001-10-31 17:05:28 PST
bug 71539 is MORE than what we really need to depend on. We really need A
fallback default font solution, but 71539 include other platform and pref UI. We
need to break down dependency , instead of build UP dependency.
Comment 14 nhottanscp 2001-11-20 13:48:03 PST
move to 0.9.8
Comment 15 Frank Tang 2002-01-16 17:53:27 PST
mass move unimportant m9.8 bug to m9.9 for now. 
Comment 16 Frank Tang 2002-02-12 19:58:59 PST
give this to nhotta and m1.0
Comment 17 Frank Tang 2002-02-15 16:59:52 PST
nsbeta1+ per triage meeting 
Comment 18 nhottanscp 2002-02-18 18:07:39 PST
Remove depends for bug 71539.
My current plan for nsbeta1 is to change the names to "Hiragano" for Japaense.
For OS9, the default "Osaka" is used. I can also change Chinese and Korean fonts
if we know the font names.

Comment 19 nhottanscp 2002-03-11 11:09:57 PST
New Japanese fonts for MacOS X.
Serif:
Hiragino Mincho Pro W3
Hiragino Mincho Pro W6

Sans Serif:
Hiragino Kaku Gothic Pro W3
Hiragino Kaku Gothic Pro W6
Hiragino Kaku Gothic Std W8

The current default for MacOS X is Osaka (for both serif and sans serif), this
is because we set defaults for MacOS 9 fonts which are not included in MacOS X.
I tried the new fonts and I actually prefer Osaka. It is more legible than
Mincho and Gothic.
Cc to momoi, I think he did a research about the default font before.

Comment 20 nhottanscp 2002-03-12 15:07:06 PST
Created attachment 73766 [details]
Screen shot Netscape JA home page with "Osaka" set as Japanese font.
Comment 21 nhottanscp 2002-03-12 15:08:59 PST
Created attachment 73767 [details]
Screen shot Netscape JA home page with "Hiragino Mincho Pro W3" set as Japanese font.
Comment 22 nhottanscp 2002-03-12 15:10:49 PST
Created attachment 73769 [details]
Screen shot Netscape JA home page with "Hiragino Kaku Gothic Pro W3" set as Japanese font.
Comment 23 nhottanscp 2002-03-12 15:17:08 PST
So I think the current font "Osaka" is fine for the MacOS X default.
Comment 24 nhottanscp 2002-03-13 16:59:31 PST
removing nsbeta+ to triage again
Comment 25 nhottanscp 2002-03-14 11:23:54 PST
nsbeta1- per i18n triage
Comment 26 Steve Dagley 2002-03-18 08:49:41 PST
Considering bug's current status removing as a blocker for 102998 
Comment 27 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2002-03-28 06:05:08 PST
> So I think the current font "Osaka" is fine for the MacOS X default.

I'm not qualified to comment on the readablility of Japanese fonts since I can't
read Japanese. However, shouldn't Mozilla have a serif font set as the Japanese
serif font and a sans-serif font as the Japanese sans-serif font? If all the
generic families map to Osaka, it defeats the purpose of having generic font
families.

This issue is probably worth revisiting when Mozilla gets Quartz font
rasterization support, since that will have an impact on the exact look of fonts.

How about the Chinese and Korean defaults?
Comment 28 Frankie 2003-02-28 11:07:51 PST
also defaults to Osaka in Mach-O 20030227
Comment 29 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2004-08-09 20:28:50 PDT
I can take it, if someone will attach the needed changes (what font for what
category for what language...).
Comment 30 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2004-12-04 10:34:17 PST
Jshin, any word here (comment 29)?
Comment 31 Smokey Ardisson (offline for a while; not following bugs - do not email) 2004-12-06 14:52:47 PST
Created attachment 168059 [details]
Gecko charsets/locales styled with CSS fonts

The Japanese changes (comment 9) seem to have been made some time ago. 
However, I'm not sure they (nor any of the Chinese or Korean fonts) are working
properly (bug 246527)?

The "copy-paste from the attached webpage into TextEdit" test reveals different
fonts being used in reality in certain cases (JP.mono, Ko.serif, Simplified and
Traditional).  "Fallback" to the OS default seems to be working in this test
(everything appears to be displayed), so it may not be anything to worry about
until bug 246527 gets fixed.
Comment 32 Smokey Ardisson (offline for a while; not following bugs - do not email) 2005-03-13 23:42:40 PST
Created attachment 177346 [details]
Gecko charsets/locales styled with CSS fonts (revised/corrected by jshin)

jshin fixed some errors in my test page over in bug 159809.  

I *think* this bug should be resolved by the patch under review in bug 159809.
Comment 33 Smokey Ardisson (offline for a while; not following bugs - do not email) 2005-10-10 20:56:56 PDT
(In reply to comment #31)

> The "copy-paste from the attached webpage into TextEdit" test reveals different
> fonts being used in reality in certain cases (JP.mono, Ko.serif, Simplified and
> Traditional).

That is because we can't copy styled text out of Gecko.  So, as far as I can
tell, this bug is fixed (and has been for some time, pre-bug 159809).

Note You need to log in before you can comment on or make changes to this bug.