Add-on menu items are not showing up in browser menu when viewing Chrome:// & Java pages

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: crazyskeggy, Unassigned)

Tracking

19 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox20 affected, firefox21 affected, firefox22 affected, firefox23 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 715957 [details]
Shows I have ABP and Phony, but no menu items.

Repro steps: 
1. Install add-ons like ABP to Firefox Beta.
2. Reboot tablet
3. Open the menu in the top-right.

Expected result:
APP's "disable on....com" shows in the menu.

Actual result:
Only 6 options show.

Extra info:
This is not a due of the "destroy all activities" bug as I do not have that dev option enabled.
Dev settings on:
Protect SD Card
USB Debug (so that I can copy files onto the device)
Show touches
Window Animation 2x
Transition Animation 1.5x
Strict mode


I am running an ASUS Transformer TF300T with Android 4.1.1.
Sriram mind taking a look at this regarding the menu and externally added items from add-ons not persisting?
Flags: needinfo?(sriram)
See Also: → bug 832990
Are the addons enabled in "Menu > Tools > Addons" in this case. There is a possibility that they are disabled due to OOM.
Flags: needinfo?(sriram)
(Reporter)

Comment 3

5 years ago
Created attachment 719566 [details]
ABP is enabled

Unfortunately, this isn't the case, as you can see in the attachment. ABP is enabled (the menu item is, however, still missing)
I see this on Nightly too

Install Adblock Plus, open the menu, dont see the Adblock Plus menu item anymore

CC'ing Wes/Margaret
Status: UNCONFIRMED → NEW
status-firefox20: --- → affected
status-firefox21: --- → affected
status-firefox22: --- → affected
Ever confirmed: true
Summary: Menu icons by Add-ons Dissappear → Add-on menu items are not showing up in browser menu anymore
Looks like this happens only when the browser has an active Chrome:// URI visible; such as the case with the default Adblock Plus settings page.

We should probably show the menu item regardless
There may be other cases, but I can clearly see this when my active tab is on the Adblock Plus installed page
Summary: Add-on menu items are not showing up in browser menu anymore → Add-on menu items are not showing up in browser menu when viewing Chrome:// URI's
Same deal with our java pages; e.g, about:addons
Summary: Add-on menu items are not showing up in browser menu when viewing Chrome:// URI's → Add-on menu items are not showing up in browser menu when viewing Chrome:// & Java pages
I think its done by ABP, and not us. We don't block any addons in about:// pages, do we?
(Reporter)

Comment 9

5 years ago
Other add-ons such as Phony and Fullll Screen do this too, though - it can't be just ABP's fault.

Comment 10

5 years ago
(In reply to Aaron Train [:aaronmt] from comment #7)
> Same deal with our java pages; e.g, about:addons

Our only Java page is about:home (about:addons is an html page). And even about:home has a real html page behind it to keep track of things like navigation state.

To try to reproduce this bug, I installed the simple view source add-on [1], and I'm still seeing it show up on about: pages (including about:home). I suspect this is an add-on specific thing, since I also have ABP installed, and its menuitem does only appear on some pages.

[1] https://addons.mozilla.org/en-us/android/addon/view-source-mobile/
(Reporter)

Comment 11

5 years ago
Quicker way to repro: close Firefox, open recent apps, swipe so that the app gets closed (either sideways or vertically, depending on whether you are on ICS/JB4.1 or JB4.2 with new launcher enabled, then reopen Firefox from the Launcher (homescreen).
This is still kind of dumb; you install Addblock Plus and you want to enable it after installing but you don't see the menu item because they supply a packaged chrome:// URL that opens after installing. You think it's broken.
tracking-fennec: --- → ?
status-firefox23: --- → affected
Is this explicit behavior from ABP
Flags: needinfo?(trev.moz)

Comment 14

5 years ago
(In reply to Brad Lassey [:blassey] from comment #13)
> Is this explicit behavior from ABP

Yes, it is. This is an action, not a status indicator. And that action only makes sense on actual web pages, elsewhere it would merely add noise to the menu.

This is a clear WONTFIX to me - at least until there are actual status indicators in Fennec (e.g. on tablets since they have large enough screens)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(trev.moz)
Resolution: --- → WONTFIX

Comment 15

5 years ago
Oh, this is filed as a Fennec bug - it's WORKSFORME then, sorry about the spam.
Resolution: WONTFIX → WORKSFORME
(Assignee)

Updated

4 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.