Browser History gets junked up

VERIFIED DUPLICATE of bug 83684

Status

()

Core
Document Navigation
VERIFIED DUPLICATE of bug 83684
17 years ago
9 years ago

People

(Reporter: sah, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Heya,

I wrote the above web page to watch different stocks I'm interested in.  
Basic layout is 2 frames, a blank one and my query page from Yahoo! Finance 
which refreshes once a minute.

When it refreshes, the back button gets junked up with multiple instances
of the page, and the back button begins to act improperly.  Looks like a 
bug in the maintenance of the history.

If you need any more info, let me know.

Cheers,

Sam

Comment 1

17 years ago
Rhino's not part of the browser. Reassigning.
Assignee: nboyd → asa
Component: Core → Browser-General
Product: Rhino → Browser
QA Contact: pschwartau → doronr
(Reporter)

Comment 2

17 years ago
ok, excuse the accusation of javascript...it happens if you visit the above
page and simply refresh it.  Could be something with the handling of history
and frames.
Summary: Javascript refresh command junks up the history list → Browser History gets junked up
(Reporter)

Comment 3

17 years ago
<sigh>, although it printed the version on the initial submit screen, i'm not
seeing it here.  So here it is:
Mozilla/5.0 (X11; U; Linux 2.2.14-5.0smp i686; en-US; rv:0.9) Gecko/20010601
<developer build>

Comment 4

17 years ago
reassign
Assignee: asa → radha
Component: Browser-General → History: Session
QA Contact: doronr → claudius
I went to the above url, clicked reload and clicked back. I could go back to the
previous page. Please provide clear steps to reproduce. I tried Beta1 bits. 
This is  very close to bug 83684

*** This bug has been marked as a duplicate of 83684 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
Okay, VERIFIED Dupe. Sam, reopen if you disagree.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.