Running reftests via |TEST_PATH=x make -C $(OBJDIR) reftest| is broken (Error: Path $OBJDIR/_tests/dist/NightlyDebug.app/Contents/MacOS/firefox-bin doesn't exist.)

RESOLVED DUPLICATE of bug 841713

Status

Testing
Reftest
RESOLVED DUPLICATE of bug 841713
5 years ago
5 years ago

People

(Reporter: jwatt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

With latest mozilla-inbound, running reftests via

TEST_PATH=x make -C $(OBJDIR) reftest

as documented in:

https://developer.mozilla.org/en-US/docs/Creating_reftest-based_unit_tests

seems to have been broken by something. I now get the error message:

Error: Path $OBJDIR/_tests/dist/NightlyDebug.app/Contents/MacOS/firefox-bin doesn't exist.
Seems mach is also broken. Same error with:

./mach reftest layout/reftests/svg/smil/
Is there a workaround for the moment in order to be able to run reftests?

Comment 3

5 years ago
I removed objdir.pth from my local virtualenv and |make reftest| works now.

I'm baffled as to why. I guess we should back out bug 841713. I'll do that now.

Comment 4

5 years ago
Will figure it out in bug 841713.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 841713
[To be clear, the patch for bug 841713 was backed out.]
The root cause here is that automation.py contains an interpolated path which is relative to the objdir directory where automation.py winds up:
http://mxr.mozilla.org/mozilla-central/source/build/automation.py.in#51
http://mxr.mozilla.org/mozilla-central/source/build/automation-build.mk#14

I...don't remember why we do things this way. Presumably we could just preprocess absolute paths into that file and use the single copy in build/.
You need to log in before you can comment on or make changes to this bug.