Closed Bug 843203 Opened 7 years ago Closed 6 years ago

Blending of pdf vector graphic broken in specific document

Categories

(Firefox :: PDF Viewer, defect, P3)

19 Branch
x86_64
Linux
defect

Tracking

()

VERIFIED FIXED
Firefox 29
Tracking Status
firefox29 --- verified
firefox30 --- verified
firefox31 --- verified

People

(Reporter: linuxhippy, Unassigned)

References

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4161 [bugday-20140423])

Attachments

(1 file)

Attached file broken_blending.pdf
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

Opend the pdf located at: http://93.83.133.214/broken_blending.pdf


Actual results:

The illustration is rendered without taking blending into account. Furthermore, the blue area seems to be rendered at a very low resultion.


Expected results:

The illustration should be rendered the same as with evince or adobe acrobat reader.
Component: Untriaged → PDF Viewer
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask]
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Depends on: 965861
Resolution: --- → FIXED
Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask] → [pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4161
Target Milestone: --- → Firefox 29
Attachment #716078 - Attachment mime type: application/octet-stream → application/pdf
Hi,

I was able to reproduce it on Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20130215 Firefox/21.0 ID:20130215031040 CSet: 953b1db7a246

I can confirm that the problem is no longer present in:

- latest Beta Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140417185217 CSet: da279b9f523a

- latest Aurora Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140423004003 CSet: 2d1b4d36eef9

- latest Nightly Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 ID:20140423030202 CSet: ac376a4e8174
Status: RESOLVED → VERIFIED
Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4161 → [pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4161 [bugday-20140423]
You need to log in before you can comment on or make changes to this bug.