Closed Bug 843265 Opened 7 years ago Closed 6 years ago

Intermittent test_play_events_2.html | Last event should be canplaythrough for http://mochi.test:8888/tests/content/media/test/seek.webm - got playing, expected canplaythrough

Categories

(Core :: Audio/Video, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla31
Tracking Status
firefox29 --- wontfix
firefox30 --- fixed
firefox31 --- fixed
firefox-esr24 --- unaffected
b2g-v1.3 --- wontfix
b2g-v1.3T --- wontfix
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: RyanVM, Assigned: jwwang)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=19913812&tree=Firefox

Android Armv6 Tegra 250 mozilla-central opt test mochitest-2 on 2013-02-20 08:02:18 PST for push 0bb9e8c676da
slave: tegra-181

85228 INFO TEST-START | /tests/content/media/test/test_play_events_2.html
85229 INFO TEST-INFO | /tests/content/media/test/test_play_events_2.html | Started Wed Feb 20 2013 08:21:15 GMT+0000 (GMT) (1361348475.537s)
85230 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | [started small-shot.ogg-0] Length of array should match number of running tests
85231 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | [started r11025_s16_c1.wav-3] Length of array should match number of running tests
85232 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got play at 0 for http://mochi.test:8888/tests/content/media/test/small-shot.ogg
85233 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got play at 0 for http://mochi.test:8888/tests/content/media/test/r11025_s16_c1.wav
85234 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got canplay at play for http://mochi.test:8888/tests/content/media/test/r11025_s16_c1.wav
85235 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got playing at canplay for http://mochi.test:8888/tests/content/media/test/r11025_s16_c1.wav
85236 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got canplaythrough at playing for http://mochi.test:8888/tests/content/media/test/r11025_s16_c1.wav
85237 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got canplay at play for http://mochi.test:8888/tests/content/media/test/small-shot.ogg
85238 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got playing at canplay for http://mochi.test:8888/tests/content/media/test/small-shot.ogg
85239 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got canplaythrough at playing for http://mochi.test:8888/tests/content/media/test/small-shot.ogg
85240 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Last event should be canplaythrough for http://mochi.test:8888/tests/content/media/test/small-shot.ogg
85241 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | [finished small-shot.ogg-0] Length of array should match number of running tests
85242 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | [started 320x240.ogv-4] Length of array should match number of running tests
85243 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got play at 0 for http://mochi.test:8888/tests/content/media/test/320x240.ogv
85244 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got canplay at play for http://mochi.test:8888/tests/content/media/test/320x240.ogv
85245 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got playing at canplay for http://mochi.test:8888/tests/content/media/test/320x240.ogv
85246 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got canplaythrough at playing for http://mochi.test:8888/tests/content/media/test/320x240.ogv
85247 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Last event should be canplaythrough for http://mochi.test:8888/tests/content/media/test/r11025_s16_c1.wav
85248 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | [finished r11025_s16_c1.wav-3] Length of array should match number of running tests
85249 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | [started seek.webm-5] Length of array should match number of running tests
85250 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got play at 0 for http://mochi.test:8888/tests/content/media/test/seek.webm
85251 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Last event should be canplaythrough for http://mochi.test:8888/tests/content/media/test/320x240.ogv
85252 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | [finished 320x240.ogv-4] Length of array should match number of running tests
85253 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | [started detodos.opus-6] Length of array should match number of running tests
85254 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got play at 0 for http://mochi.test:8888/tests/content/media/test/detodos.opus
85255 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got canplay at play for http://mochi.test:8888/tests/content/media/test/seek.webm
85256 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got playing at canplay for http://mochi.test:8888/tests/content/media/test/seek.webm
85257 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got canplay at play for http://mochi.test:8888/tests/content/media/test/detodos.opus
85258 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got playing at canplay for http://mochi.test:8888/tests/content/media/test/detodos.opus
85259 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got canplaythrough at playing for http://mochi.test:8888/tests/content/media/test/detodos.opus
85260 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Last event should be canplaythrough for http://mochi.test:8888/tests/content/media/test/detodos.opus
85261 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | [finished detodos.opus-6] Length of array should match number of running tests
85262 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_play_events_2.html | Last event should be canplaythrough for http://mochi.test:8888/tests/content/media/test/seek.webm - got playing, expected canplaythrough
85263 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | [finished seek.webm-5] Length of array should match number of running tests
85264 INFO TEST-INFO | /tests/content/media/test/test_play_events_2.html | Finished at Wed Feb 20 2013 08:21:21 GMT+0000 (GMT) (1361348481.231s)
85265 INFO TEST-INFO | /tests/content/media/test/test_play_events_2.html | Running time: 5.694s
85266 INFO TEST-END | /tests/content/media/test/test_play_events_2.html | finished in 6123ms
(OrangeWFM bugs not touched for 2 months)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
BTW, isn't this a dupe of bug 836851 ?
Apparently not.

https://tbpl.mozilla.org/php/getParsedLog.php?id=33299219&tree=Fx-Team
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
02:10:43     INFO -  1446 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got canplaythrough at playing for http://mochi.test:8888/tests/content/media/test/seek.webm
02:10:43     INFO -  1447 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got canplay at canplaythrough for http://mochi.test:8888/tests/content/media/test/seek.webm
02:10:43     INFO -  1448 INFO TEST-PASS | /tests/content/media/test/test_play_events_2.html | Check expected event got playing at canplay for http://mochi.test:8888/tests/content/media/test/seek.webm

The last 3 events are canplaythrough, canplay, and playing. Since readyState==HAVE_ENOUGH_DATA is just an estimation, It could change whenever download speed or playback rate change. I don't understand why the test checks if the last event is canplaythrough.
Flags: needinfo?(kinetik)
After reading the Bug 569301, I think this test is to test the 3 ways to register an event handler. The sequence of media events should not matter. Since 'canplaythrough' is just an estimation and will not necessarily come. I suggest to remove the check for last event == 'canplaythrough'. Is that OK?
Flags: needinfo?(bugs)
(In reply to JW Wang[:jwwang] from comment #46)
> The last 3 events are canplaythrough, canplay, and playing. Since
> readyState==HAVE_ENOUGH_DATA is just an estimation, It could change whenever
> download speed or playback rate change. I don't understand why the test
> checks if the last event is canplaythrough.

(In reply to JW Wang[:jwwang] from comment #85)
> After reading the Bug 569301, I think this test is to test the 3 ways to
> register an event handler. The sequence of media events should not matter.
> Since 'canplaythrough' is just an estimation and will not necessarily come.
> I suggest to remove the check for last event == 'canplaythrough'. Is that OK?

That check doesn't seem valid, so I think it's fine to remove it.  Is test_play_events failing the same way? That has the same check...
Flags: needinfo?(kinetik)
(In reply to Matthew Gregan [:kinetik] from comment #140)
> That check doesn't seem valid, so I think it's fine to remove it.  Is
> test_play_events failing the same way? That has the same check...

Do you mean Bug 969392? I think so.