Migrate NSPR from CVS to Mercurial

RESOLVED DUPLICATE of bug 844385

Status

RESOLVED DUPLICATE of bug 844385
6 years ago
6 years ago

People

(Reporter: joduinn, Assigned: wtc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Similar to bug#815169 (Migrate NSS from CVS to Mercurial)...but spinning out as separate bug as it has important differences.
There's been some back/forth in irc+meetings about the exact code layout of NSS, NSPR code in the proposed new NSS, NSPR repos... and how similar/different it would be to the copy of NSS/NSPR being landed into mozilla-central. This has impact on the process for getting new drops of NSS/NSPR into mozilla-central/aurora/beta/release/esr. 

Until that is resolved, however, we believe this cvs-to-hg migration work can be done most quickly in hg using either a user-repo or any available disposable project branch (https://wiki.mozilla.org/ReleaseEngineering/DisposableProjectBranches). 

Once this cvs-to-hg migration and directory structure has been figured out, we can unblock bug#843380, bug#843381 to create new hg repos, enable appropriate vcs2vcs mirroring, and we can initialize the repos to the agree-upon code+directory structure.

Comment 2

6 years ago
This has become unnecessary.

I already completed a full migration of the relevant CVS portions to HG, including full history.

I've handed the resulting files to Mozilla IT in bug 844385.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 844385
You need to log in before you can comment on or make changes to this bug.