64-bit xulrunner is nsXULRunnerApp.cpp; 32-bit xulrunner is nsXULStub.cpp

RESOLVED WORKSFORME

Status

Toolkit Graveyard
XULRunner
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: Simon Kornblith, Unassigned)

Tracking

19 Branch
x86
Mac OS X

Details

(Reporter)

Description

6 years ago
As of XULRunner 19, the "xulrunner" executable in XUL.framework/Versions/Current seems to have multiple personality disorder, as evidenced by the following output:

$ arch -i386 ./xulrunner 
Could not read application.ini

$ arch -x86_64 ./xulrunner 
Mozilla XULRunner 19.0

Usage: xulrunner [OPTIONS]
       xulrunner APP-FILE [APP-OPTIONS...]
[...]

Examining the executable with strings -arch i386 and strings -arch x86_64 suggests that the 32-bit executable is being built from xulrunner/stub/nsXULStub.cpp, while the 64-bit executable is being built from xulrunner/app/nsXULRunnerApp.cpp. These are then being unified into a universal binary that behaves very differently across architectures.

In XULRunner 18.0.2, the xulrunner executable was built from nsXULRunnerApp.cpp on both 32-bit and 64-bit architectures.
(Reporter)

Comment 1

6 years ago
This seems to be fixed in the XULRunner 20 betas, so this can be closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

3 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.