Set WebRTC video defaults to 30 FPS and put prefs in all.js for easy about:config editing

RESOLVED DUPLICATE of bug 842715

Status

()

defect
RESOLVED DUPLICATE of bug 842715
7 years ago
6 years ago

People

(Reporter: dmose, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [getUserMedia][blocking-gum-][android-trunk-needed][android-webrtc+])

Attachments

(1 attachment)

+++ This bug is a followon for Bug #842715 +++

After discussion with jesup and mreavy, this is two minor tweaks to the gUM prefs, initially for landing on alder, later for uplift to mozilla-central.
Summary: Set FPS defaults to 30 and put prefs in all.js for easy about:config editing → Set WebRTC video defaults to 30 FPS and put prefs in all.js for easy about:config editing
Whiteboard: [getUserMedia][blocking-gum-] → [getUserMedia][blocking-gum-][android-trunk-needed]
Attachment #716371 - Attachment description: default prefs and set default fps to 30 → default prefs and set default fps to 30 (landed on alder)
Whiteboard: [getUserMedia][blocking-gum-][android-trunk-needed] → [getUserMedia][blocking-gum-][android-trunk-needed][android-webrtc+]
Comment on attachment 716371 [details] [diff] [review]
default prefs and set default fps to 30 (landed on alder)

Review of attachment 716371 [details] [diff] [review]:
-----------------------------------------------------------------

and minfps is actually the one that's used for many things, not fps!

::: modules/libpref/src/init/all.js
@@ +178,5 @@
>  pref("media.navigator.enabled", true);
> +pref("media.navigator.video.default_width", 640);
> +pref("media.navigator.video.default_height", 480);
> +pref("media.navigator.video.default_fps", 30);
> +pref("media.navigator.video.default_min", 10);

minfps....
Attachment #716371 - Flags: review-
Is this already landed at this point? Is there any work left to do here?
Flags: needinfo?(rjesup)
Landed on m-i/m-c via bug 842715
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(rjesup)
Resolution: --- → DUPLICATE
Duplicate of bug: 842715
No longer blocks: android-webrtc
You need to log in before you can comment on or make changes to this bug.