Flash bypasses Flashblock on recent nightly

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Shaddy Baddah, Unassigned)

Tracking

22 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:22.0) Gecko/20130220 Firefox/22.0
Build ID: 20130220031126

Steps to reproduce:

I visited the following web page:

http://www.smh.com.au/technology/sci-tech/cosmic-quarries-a-new-frontier-for-mineral-exploration-20130220-2erm0.html



Actual results:

The flash content was played, and not blocked as usual by Flashblock


Expected results:

The flash content should have been blocked.
(Reporter)

Comment 1

4 years ago
This seems to have started happening in a recent Nightly, perhaps since around 15 Feb 2013. I will try and bisect which at some point. This seems to be similar to Bug 652300. I've also started having issues with high cpu usage in the same recent timeframe, but this does not suggest the issue is related.
(Reporter)

Comment 2

4 years ago
Investigating, the last known good was:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-02-14-03-28-50-mozilla-central/firefox-21.0a1.en-US.win64-x86_64.zip

Everything since fails to block flash.
(Reporter)

Comment 3

4 years ago
about:buildconfig lists the source for the last known good as:

http://hg.mozilla.org/mozilla-central/rev/aceeea086ccb

and the next nightly at http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-02-15-03-10-40-mozilla-central/ list the source as:

http://hg.mozilla.org/mozilla-central/rev/953b1db7a246

Hope that helps.
Per previous Comment: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=aceeea086ccb&tochange=953b1db7a246
Keywords: regression, regressionwindow-wanted

Comment 5

4 years ago
Sorry this is a known problem. I've fixed it in my tree and you can get it from:
http://flashblock.mozdev.org/installation1.html#unstable (Flashblock 1.5.unstable). I also need to update the what's new and upload it to addons.mozilla.org. Sorry for the lack of timeliness on my part. 

FYI: expected fallout from Bug 834697 (Enable XBL Scopes)
Keywords: regression, regressionwindow-wanted
Blocks: 834697
Component: Untriaged → Extension Compatibility
(Reporter)

Comment 6

4 years ago
Hi Philip. That worked for me. Thanks. Should I close this bug?

Comment 7

4 years ago
Fixed by uploading Flashblock v1.5.17 to addons.mozilla.org.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.