[Progress Events] Remove support for ProgressEvent.initProgressEvent() and Document.createEvent("ProgressEvent")

RESOLVED FIXED in mozilla22

Status

()

Core
DOM: Events
RESOLVED FIXED
4 years ago
8 months ago

People

(Reporter: Jungkee Song, Assigned: emk)

Tracking

({dev-doc-complete, site-compat})

unspecified
mozilla22
x86_64
Linux
dev-doc-complete, site-compat
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.70 Safari/537.17

Steps to reproduce:

ProgressEvent CR (http://www.w3.org/TR/progress-events/) test
- Test wiki: http://www.w3.org/wiki/Webapps/Interop/ProgressEvents
- Test suite: http://w3c-test.org/webapps/ProgressEvents/tests/
- Test case: http://w3c-test.org/webapps/ProgressEvents/tests/submissions/Ms2ger/constructor.html



Actual results:

Test case failed: Object created from ProgressEvent interface has a initProgressEvent() method.


Expected results:

Object created from ProgressEvent interface should not have initProgressEvent() method anymore.

initProgressEvent() had been present until
<http://www.w3.org/TR/2011/WD-progress-events-20110310/> version and removed
from <http://www.w3.org/TR/2011/WD-progress-events-20110809/> version. As
it's been replaced by constructor, it may not be supported any more.
Thanks for the cc, though I'm not sure why you cc'd me...

What do the WHATWG specs say on this?
(Assignee)

Comment 2

4 years ago
WHATWG spec no longer defines initProgressEvent, either.
http://xhr.spec.whatwg.org/#interface-progressevent
(Assignee)

Comment 3

4 years ago
Also, WebKit already removed initProgressEvent.
https://bugs.webkit.org/show_bug.cgi?id=71340

Comment 4

4 years ago
This bug is valid, but odd testcase. What if some "LegacyEvents" spec added initProgressEvent.
Implementing such spec without causing test failures wouldn't be possible.
If that happens, I'll happily update the test :)
(Assignee)

Comment 6

4 years ago
Created attachment 717343 [details] [diff] [review]
Make initProgressEvent() [noscript]

I left the function for C++ callers because the ProgressEvent constructor is hard to call from C++.
I didn't bump the iid because this will not change the binary layout.
Assignee: nobody → VYV03354
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #717343 - Flags: review?(bugs)

Comment 7

4 years ago
Comment on attachment 717343 [details] [diff] [review]
Make initProgressEvent() [noscript]

Do other browser have initProgressEvent?
Attachment #717343 - Flags: review?(bugs) → review+
(Assignee)

Comment 8

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/64d47c0e35a8
Ms2ger's test should be imported.

(In reply to Olli Pettay [:smaug] from comment #7)
> Do other browser have initProgressEvent?

Chrome does not support initProgressEvent (see comment #3).
IE10 has initProgressEvent, but it doesn't support ProgressEvent in the first place.
I don't care about dying Presto anymore.
Flags: in-testsuite?
(Assignee)

Comment 9

4 years ago
> it doesn't support ProgressEvent
it doesn't support ProgressEvent constructor
Comment on attachment 717343 [details] [diff] [review]
Make initProgressEvent() [noscript]

Actually, since we support .createEvent("progressevent"), we should have
initProgressEvent too.
So either remove both or keep them both.
Attachment #717343 - Flags: review+ → review-
(Assignee)

Comment 11

4 years ago
Created attachment 717404 [details] [diff] [review]
Drop support for .createEvent("progressevent")
Attachment #717404 - Flags: review?(bugs)
(Assignee)

Updated

4 years ago
Whiteboard: [leave open]
Comment on attachment 717404 [details] [diff] [review]
Drop support for .createEvent("progressevent")

This all is tiny bit risky since IE supports this.
But better to try this now, early in cycle.
Attachment #717404 - Flags: review?(bugs) → review+
(Assignee)

Comment 13

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c2c1e378ab49
Whiteboard: [leave open]
https://hg.mozilla.org/mozilla-central/rev/64d47c0e35a8
https://hg.mozilla.org/mozilla-central/rev/c2c1e378ab49
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22

Updated

4 years ago
Keywords: dev-doc-needed
Summary: [Progress Events] There must not be a initProgressEvent(). → [Progress Events] Remove support for ProgressEvent.initProgressEvent() and Document.createEvent("ProgressEvent")
I've added this bug to the compatibility doc. Please correct the info if wrong.
https://developer.mozilla.org/en-US/docs/Site_Compatibility_for_Firefox_22
We need an update to https://developer.mozilla.org/en-US/docs/XPCOM_Interface_Reference/NsIDOMProgressEvent too.

Updated

4 years ago
Depends on: 870466

Updated

4 years ago
Keywords: site-compat
Updated:
https://developer.mozilla.org/en-US/docs/Web/API/ProgressEvent.initProgressEvent
https://developer.mozilla.org/en-US/docs/Web/API/ProgressEvent
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Releases/22
https://developer.mozilla.org/en-US/docs/Web/API/document.createEvent (this article is in need of a complete rewrite, so I did the minimum here)
and
https://developer.mozilla.org/en-US/docs/XPCOM_Interface_Reference/NsIDOMProgressEvent
Keywords: dev-doc-needed → dev-doc-complete
Depends on: 1314303
You need to log in before you can comment on or make changes to this bug.