Closed Bug 843699 Opened 9 years ago Closed 5 years ago

PDF Viewer not opening link containing javascript

Categories

(Firefox :: PDF Viewer, defect, P3)

19 Branch
x86_64
Windows 7
defect

Tracking

()

RESOLVED FIXED
Firefox 52

People

(Reporter: susiecopenhaver, Unassigned)

References

Details

(Whiteboard: [pdfjs-c-feature][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/7794)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

I generate some pdfs that have links that contain javascript (javascript: window.open('url'); void(0);). The links do not work in the pdf viewer.


Actual results:

The link does not work and if I right click and open in new window it sends me to resource://pdf.js/web/.


Expected results:

The javascript should open the page in a new tab/window. This works in all other browsers and if I switch the action from 'preview in FFox' to 'Use Adobe Acrobat' in FF preferences, it works as well.
Component: Untriaged → PDF Viewer
Duplicate of this bug: 843741
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Whiteboard: [pdfjs-c-feature]
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [pdfjs-c-feature] → [pdfjs-c-feature][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/7794
Target Milestone: --- → Firefox 52
You need to log in before you can comment on or make changes to this bug.