When switching between different prefs panels, no redraw

VERIFIED FIXED in M9

Status

()

Core
XUL
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: Prashant Desale, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Clicking catagory "Advanced" in preferences window does not show advanced
preferences to select, and it crashes whole application.

Product: Seamonkey [Apprunner]
Build: 1999-06-17-08.
OS: Windows-95.

STEPS TO REPRODUCE:
1] Open apprunner.exe on win95.
2] Select menu "Edit" and click "Preferences".
3] It will open another window, in order to allow user to select his
preferences.
4] On preferences window, scroll down in catagory untill you see catagory
"Advanced".
5] Now click this catagory "Advanced". [Here it should show advanced preferences
to select, but it does not.]
6] Still if you don't see application crash, then double click this catagory
"Advanced" again.

EXPECTED RESULTS:
Preferences window should show advanced preferences to select. Application
should not crash.

ACTUAL RESULTS:
After clicking catagory "Advanced" in preferences window, it does not show
advanced preferences to select. Application crashes.

DEPENDENCY:
Testing  of bug# 5352 totally depends on this bug, and bug# 5352 is QA Blocker
bug. Untill this is fixed, we won't be able to select advanced preference
"Enable Java", and bug# 5352 can not be tested.
(Reporter)

Updated

19 years ago
Summary: Preferences window causes crashing application. → Preferences window causes Application crash.
(Reporter)

Comment 1

19 years ago
Right now I'm not sure whether it should go to Pref UI or not. Other day when I
was talking to vidur, I remember him mentioning that Preferences functionality
is not in there yet.
So if Component is wrong, please reassign.

Christopher, can I change QA contact to myself ?
I would like to follow up this bug.

Updated

19 years ago
Assignee: shuang → joki
Component: Pref UI → Event Handling
Summary: Preferences window causes Application crash. → Multiple clicks in prefs window crash app

Comment 2

19 years ago
Easier steps to reproduce:

- launch apprunner
- open prefs
- click repeatedly on 'Advanced' (other ones work too)

A talkback report was generated; 10117815.
(http://cyclone/reports/incidenttemplate.CFM?reportID=124&style=0&tc=53&cp=1&ck1
=SUser+email+address&cd1=%25bear%40netscape%2Ecom%25&co1=like&bbid=10117815)

BTW, desale, I have no difficulties viewing the Advanced prefs; it's the
multiple clicks that bung up the app. Changing area to event handling as this is
nothing to do with UI.

Application exception occurred:
        App:  (pid=219)
        When: 6/17/1999 @ 15:16:43.798
        Exception number: c0000005 (access violation)

The function at the stop of the stack was AddScriptEventListener; cc'ing
waterson as his change to line 2000 was where the app crashed (I think):

if (NS_OK == owner->GetScriptContext(&context)) {
(Reporter)

Comment 3

19 years ago
I cant view Advanced prefs at all. As soon as I click "Adavanced" It starts
showing some checkboxes and whole UI gets messed up.

Updated

19 years ago
Assignee: joki → waterson

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M8

Comment 4

19 years ago
This looks okay for me -- almost. I see UI get drawn, but it looks like it gets
drawn _on_top_of_ whatever was there before. Try clicking "advanced", and then
re-sizing the window ever so slightly...

Not sure joki is the right person to be looking at this -- reassigning to self
because it looks to me like a problem with XUL in an iframe. Added mcmullen to
cc list, as well.

Comment 5

19 years ago
Set milestone to M8.

Comment 6

19 years ago
desale is now able to set prefs in the advanced pane. however, the primary
problem has to do with multiple clicks in the prefs window... that's a crasher.
(Reporter)

Comment 7

19 years ago
Yeah, I can see preferences now. The only Crasher is problem now.

Comment 8

19 years ago
A funny thing: this would be a dup of another bug, except that both bugs refer to
two unrelated issues in the same breath: the crashing when you switched panels,
and the bad redraw.

The crashes on mmultiple clicks were an M7 stopper, now fixed. (#7902). This bug
might as well represent the bad refresh problem (which remains), and I suggest
the bug summary be completely changed to reflect this.

Updated

19 years ago
Assignee: waterson → shuang
Status: ASSIGNED → NEW
Component: Event Handling → Pref UI
Summary: Multiple clicks in prefs window crash app → When switching between different prefs panels, no redraw

Comment 9

19 years ago
OK, got it. Changing summary. This bug now reflects the following problem:

- Launch apprunner
- Open prefs
- Click on Advanced. The window is NOT redrawn/refreshed to show the prefs
correctly - it looks as if the new is redrawn over/under the old. Resizing the
prefs window at this point forces a redraw.

Comment 10

19 years ago
so who wants to own this since I can't fix it ;-) sorry.
hyatt? mcmullen? anyone?

Updated

19 years ago
Assignee: shuang → hyatt
Component: Pref UI → XUL

Comment 11

19 years ago
I'm changing the component to XUL, since the layoout of this frame broke when we
converted the frame URLs from HTML to XUL format.

Somehow, loading new XUL into a frame fails to refresh. The same problem does not
happen with HTML. Maybe a layout bug, maybe a XUL bug...trying hyatt.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Target Milestone: M8 → M9
(Assignee)

Comment 12

19 years ago
Problem existed prior to box/intrinsic sizing/troy's hashtable horkage.  Letting
it slide to M9.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

19 years ago
Got it. An extra repaint on the end document load did the trick.

Updated

19 years ago
Whiteboard: 9 July: Can't get to this particular pref

Updated

19 years ago
QA Contact: cpratt → desale
Whiteboard: 9 July: Can't get to this particular pref

Comment 14

19 years ago
Seems good using the '1999071310' build (which seems to actually be a July 14
build?) under Windows 98. Reassigning to desale so that he can verify under
Windows 95.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 15

19 years ago
Working fine now. Verified.

Comment 16

19 years ago
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: desale → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.