Closed Bug 844106 Opened 8 years ago Closed 8 years ago

Use Unicode 6.1 data to improve IDN script-mixing checks

Categories

(Core :: Internationalization, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 737931

People

(Reporter: gerv, Unassigned)

References

()

Details

Our IDN mixed-script implementation currently does not restrict characters labelled as "Common" or "Inherited".

https://wiki.mozilla.org/IDN_Display_Algorithm says:

Some Common or Inherited characters are only used in a small number (but more than one) script. Mark Davis writes: "The Unicode Consortium in U6.1 (due out soon) is adding the property Script_Extensions, to provide data about characters which are only used in a few (but more than one) script. The sample code in #39 should be updated to include that, so handling such cases." This data is now available, but not yet in the Firefox platform. In the mean time, Common and Inherited characters are permitted without restriction.

This bug covers updating Firefox to take account of the data from Unicode 6.1 to make sure that Common or Inherited characters used in only a few scripts count as part of those scripts, rather than as Common or Inherited.

Gerv
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 737931
You need to log in before you can comment on or make changes to this bug.