[linux powerpc] some images are blue after update to ff 19 with the high quality image downscaler

RESOLVED DUPLICATE of bug 817356

Status

()

RESOLVED DUPLICATE of bug 817356
6 years ago
5 years ago

People

(Reporter: pedretti.fabio, Unassigned)

Tracking

({regression})

19 Branch
PowerPC
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux ppc; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130218104019

Steps to reproduce:

Open a random site with png or jpg images on it (e.g. search on google images).


Actual results:

Many images (happens on both png and jpg) have a blu tint. It happens that the image loads fine (colors are OK), but when completely loaded a "blu layer" appears on it. Strangely when the same image is shown more time on the same page not all have the blu tint.


Expected results:

Images have correct colors as it happened on firefox <= 18. This happened after upgrading to ff 19 on a Ubuntu 12.04 (official ubuntu packages) on a powerpc G4 machine.

Comment 1

6 years ago
1) Test with a fresh profile, see https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

2) If images are normal in FF18-, so there is maybe a regression.
Use the tool mozregression to find a possible regression range, see 
http://harthur.github.com/mozregression/
(ex: mozregression --good=2012-08-01)
Flags: needinfo?(fabio.ped)
Summary: [linux powerpc] some images are blu after update to ff 19 → [linux powerpc] some images are blue after update to ff 19
(Reporter)

Comment 2

6 years ago
I did a "mv .mozilla .mozilla_backup", started ff and confirmed the blu images. When trying a bisect I get:

$ mozregression --good=2012-08-01
Downloading nightly from 2012-11-12
Installing nightly
Starting nightly
['moznightlyapp/firefox/firefox', '-profile', '/tmp/tmpteutxk.mozrunner']
Traceback (most recent call last):
  File "/usr/local/bin/mozregression", line 9, in <module>
    load_entry_point('mozregression==0.6.4', 'console_scripts', 'mozregression')()
  File "/usr/local/lib/python2.7/dist-packages/mozregression/regression.py", line 187, in cli
    bisector.bisect(get_date(options.good_date), get_date(options.bad_date))
  File "/usr/local/lib/python2.7/dist-packages/mozregression/regression.py", line 108, in bisect
    dest = self.runner.start(midDate)
  File "/usr/local/lib/python2.7/dist-packages/mozregression/runnightly.py", line 237, in start
    if not self.app.start(self.profile, self.addons, self.cmdargs):
  File "/usr/local/lib/python2.7/dist-packages/mozregression/runnightly.py", line 141, in start
    self.runner.start()
  File "/usr/local/lib/python2.7/dist-packages/mozrunner/runner.py", line 183, in start
    self.process_handler.run(timeout, outputTimeout)
  File "/usr/local/lib/python2.7/dist-packages/mozprocess/processhandler.py", line 621, in run
    self.proc = self.Process(self.cmd, **args)
  File "/usr/local/lib/python2.7/dist-packages/mozprocess/processhandler.py", line 76, in __init__
    universal_newlines, startupinfo, creationflags)
  File "/usr/lib/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1249, in _execute_child
    raise child_exception
OSError: [Errno 8] Exec format error
Exception AttributeError: "'ProcessHandler' object has no attribute 'proc'" in <bound method Runner.cleanup of <mozrunner.runner.Runner object at 0x10f71530>> ignored
Flags: needinfo?(fabio.ped)
mozregression will not work because we don't have PPC builds, only x64 and X86.
( ftp://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central/ )

Reporter: Please set image.high_quality_downscaling.enabled to false in about:config and test again.
gfx.color_management.mode to 0 would be another thing to try.
(Reporter)

Comment 4

6 years ago
OK, can you tell me how to purge all things installed with "sudo pip install mozregression"?

Just setting image.high_quality_downscaling.enabled to false fixes the problem.
(In reply to Fabio from comment #4)
> OK, can you tell me how to purge all things installed with "sudo pip install
> mozregression"?

sudo pip uninstall mozregression ? (just a guess)
 
> Just setting image.high_quality_downscaling.enabled to false fixes the
> problem.

thanks, it seems to be a regression from bug 486918
Blocks: 486918
Component: Untriaged → ImageLib
Keywords: regression
Product: Firefox → Core
Hardware: Other → PowerPC
Summary: [linux powerpc] some images are blue after update to ff 19 → [linux powerpc] some images are blue after update to ff 19 with the high quality image downscaler

Comment 6

6 years ago
(In reply to Matthias Versen [:Matti] from comment #5)
> thanks, it seems to be a regression from bug 486918

But bug 486918 landed in FF18, no? So why did the reporter see the issue only after upgrading to FF19?
It got disabled on Firefox18 (see bug 829940)
I think this is Linux-specific. No such issue with TenFourFox on OS X PPC, but it's also not using the same downscaler.
I should also add that the problem is likely an endianness flaw in Skia; it has never been tested on big-endian platforms. This is not really something I can advise on because TenFourFox doesn't use Skia either (only CG). Perhaps Tobias has an idea.

Comment 10

6 years ago
I can confirm this bug and the workaround.  It has been reported on launchpad (https://bugs.launchpad.net/firefox/+bug/1130857 ).  The debian PowerPC mailing list also has the problem reported (http://lists.debian.org/debian-powerpc/2013/02/msg00028.html ).  Is the patch in mozilla bug 817356 the fix for this?
Joe could answer the question if this is a dupe of bug 817356.

btw: Thanks Cameron for commenting and confirming that this could be a skia issue !
Status: UNCONFIRMED → NEW
Ever confirmed: true
Looking at the code, I'm pretty sure this is a dupe of bug 817356, yes.

Updated

6 years ago
(Reporter)

Comment 13

5 years ago
Confirmed fixed (and duplicate).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 817356
You need to log in before you can comment on or make changes to this bug.