Switching to/from fullscreen stops the video, forces rebuffering

RESOLVED WONTFIX

Status

()

defect
--
major
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: BenB, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

6 years ago
Firefox: 20.0a1 2013-01-04 self-compiled 64bit
OS: Ubuntu Linux 12.04 64bit
Video driver: nouveau (nvidia gfx card, open source driver, moderately 3D accelerated)
Screen: 2 monitors, each 1920x1200, playing on main screen
Internet connection: 20 MBit/s
Addons and Plugins: None

Reproduction:
1. Create fresh profile
2. Go to YouTube video page <http://www.youtube.com/watch?v=wsuizJmZ3gU>
3. Wait until the video starts
4. Click the fullscreen button (bottom right of the video player)

(Whether "Always allow fullscreen for youtube.com" is enabled or not is irrelevant, the bug happens in both cases)

Actual result:
During step 2, you see the throbber (circle with dots), but it's frozen. The video starts to play after about 10 seconds.
After step 2, it plays normally and smoothly
After step 3, the video abruptly stops. I see the video frame that last played, in fullscreen, audio stopped, and the throbber appears, and is frozen.
Normally, it stays like that - I waited more than 1 minute, and the video did not resume. Sometimes, it does resume, but only after 30-60 seconds.

Expected result:
After step 3, the video continues without any interruption or gap in playback.
I should be able to change in and out of fullscreen at will, without the playback being affected at all, just the size changed.

Importance:
This makes fullscreen mode effectively unusable for me.
And without fullscreen, YouTube videos are poststamp size for me and no fun. Essentially, this massively cripples youtube experience. Thus, this deserves Severity: Major.

Narrowing down:
1. This bug consistently does happen on <http://www.youtube.com/watch?v=wsuizJmZ3gU> (consistently)
2. This bug consistently does *not* happen on <http://www.youtube.com/watch?v=pgdGY2W1wyo>
3. This bug does *not* happen on <http://www.heise.de/video/artikel/Medienzentrale-XBMC-12-Live-TV-Android-1800989.html>

I've tried this with my main profile and a fresh profile, no plugins, no addons, no proxy, and I tried many times, and I consistently get the same results.

I'm fairly sure I've seen the bug on sites other than YouTube.

Related bugs:
Bug 453063, bug 513144
Reporter

Comment 1

6 years ago
Lovely bug number!
Reporter

Comment 2

6 years ago
> During step 2, ... After step 2, ... After step 3, 

Sorry! Add 1 to all step numbers. (I added "step 1: create profile" afterwards and forgot to adjust the step numbers)
YouTube switches video resolutions when the player resizes, which is why the video must rebuffer.

For example, with the first video, click the gear icon and it'll show you the initial resolution (480p for me, I have YouTube set to larger videos by default).  Fullscreen, then click the gear icon again, and you'll see the resolution has switched to 720p.

Note that the second video is only available in 360p, so there's no resolution switch when changing player sizes.

You can change this behaviour in YouTube's playback settings: https://www.youtube.com/account_playback
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Reporter

Comment 4

6 years ago
I don't care what YouTube does, this is broken. I need to be able to direct *my* video player software (Firefox) to do what *I* want. If the web API lets the site get in the middle of that, then the API is broken. An important point of <video> for me is that *I* am back in control, not some Flash script. Even if the site doesn't *want* to offer me fullscreen, I should still be able to do it, because it's my software, my useragent.

FWIW, I took more than 1 hour to create this bug report.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Reporter

Comment 5

6 years ago
> You can change this behaviour in YouTube's playback settings: https://www.youtube.com/account_playback

(FWIW, I can't, because this requires a Google login, which I intentionally don't have.)

Basic video playing features need to be available independent of what the website does.
We will not make this change.

Making this change would cause us to be incompatible with the spec. If you want to make this change please take the issue up with the W3C, and get back to us if and when the spec changes.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → INVALID
Reporter

Comment 7

6 years ago
1. So why does it not resume playing? It's not a lack of bandwidth.

> Actual result:...
> Normally, it stays like that - I waited more than 1 minute, and the video did not resume.

2. Do you mean the HTML5 feature requestFullscreen() / onfullscreenchange, which is independent from <video>? Where in the spec does it say that the user agent cannot offer a UI feature to the end user to view the video (not the page) as full screen? I need a useragent feature, not a website feature.
Status: RESOLVED → VERIFIED
Reporter

Comment 8

6 years ago
> Making this change would cause us to be incompatible with the spec.

You haven't explained which part of the spec disallows the user agent by itself to offer a "full screen" feature.
Status: VERIFIED → REOPENED
Resolution: INVALID → ---
Reporter

Comment 9

6 years ago
(i.e. maximize the currently playing video to full screen. Not the webpage to fullscreen.)
(In reply to Ben Bucksch (:BenB) from comment #7)
> 1. So why does it not resume playing? It's not a lack of bandwidth.

Comment 3 explains it.

> > Actual result:...
> > Normally, it stays like that - I waited more than 1 minute, and the video did not resume.
> 
> 2. Do you mean the HTML5 feature requestFullscreen() / onfullscreenchange,
> which is independent from <video>? Where in the spec does it say that the
> user agent cannot offer a UI feature to the end user to view the video (not
> the page) as full screen? I need a useragent feature, not a website feature.

It's already there in the context menu for <video>. Youtube disables this. You can prevent it from doing that by setting dom.event.contextmenu.enabled to false.
No longer blocks: 453063
Reporter

Comment 11

6 years ago
Ah, thanks.

> > 1. So why does it not resume playing? It's not a lack of bandwidth.

> Comment 3 explains it.

That only explains why there is a short delay for resume. I would expect that delay to be the same as the initial delay, or slightly longer (due to larger resolution). But the initial delay after page load is maybe 2-3s, and the delay after switching to/from fullscreen is 30-60s. Even when I switch back to normal mode, it takes almost 1 minute to resume playing. That's definitely a bug somewhere.

Also compare bug 876241.

> It's already there in the context menu for <video>. Youtube disables this. 

Ah, I see, thanks. Then consider this bug (in addition to the actual bug above) an end user request to:
- Add a more discoverable UI element (e.g. on mouse hover)
- Do not let the website disable it
  (Firefox is a *user* agent, not an agent for Google, compare bug 86194)
Blocks: useragent
(In reply to Ben Bucksch (:BenB) from comment #11)
> Then consider this bug (in addition to the actual bug
> above) an end user request to:
> - Add a more discoverable UI element (e.g. on mouse hover)
> - Do not let the website disable it
>   (Firefox is a *user* agent, not an agent for Google, compare bug 86194)

No, we're not going to add UI like that. Feel free to write an add-on which does so.

You've now had 3 separate people close this bug. Please do not further reopen or repurpose this bug until you've had a module owner agree to do so.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WONTFIX
(Briefly: the site isn't doing anything malicious/abusive, and the UI suggested in comment 11 seems exceptionally unlikely to be useful to the general Firefox userbase. That fails the basic sanity check commonly used for if we should add UI or not. If you don't like the way a site works feel free to stop using it or install an addon to customize your experience.)
Reporter

Comment 14

6 years ago
> If you don't like the way a site works feel free to stop using it

That's not very practical for youtube.com, and you know it. Please see bug 86194 introduction for philosophical background.

I also don't think that I should need an extension for something as basic as fullscreen video, on all <video> websites, no exceptions.

But I won't reopen, per your wish.
You need to log in before you can comment on or make changes to this bug.