Last Comment Bug 844792 - Warn about the upcoming removal of multipart support in XHR
: Warn about the upcoming removal of multipart support in XHR
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla22
Assigned To: Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01)
:
Mentors:
Depends on:
Blocks: 843508
  Show dependency treegraph
 
Reported: 2013-02-25 05:28 PST by Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01)
Modified: 2013-04-04 13:53 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Add a warning (3.20 KB, patch)
2013-02-25 05:30 PST, Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01)
bugs: review+
Details | Diff | Splinter Review
Adjust warning text, make non-localizable (3.74 KB, patch)
2013-03-01 01:14 PST, Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01)
bugs: review+
Details | Diff | Splinter Review
Merged patch for aurora (1.34 KB, patch)
2013-03-01 07:21 PST, Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01)
hsivonen: review+
bajaj.bhavana: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2013-02-25 05:28:33 PST
Warn ahead of bug 843508.
Comment 1 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2013-02-25 05:30:37 PST
Created attachment 717835 [details] [diff] [review]
Add a warning
Comment 2 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2013-02-25 07:13:08 PST
Thanks.

https://hg.mozilla.org/integration/mozilla-inbound/rev/e9e4dab21e79
Comment 3 Ryan VanderMeulen [:RyanVM] 2013-02-25 18:38:36 PST
https://hg.mozilla.org/mozilla-central/rev/e9e4dab21e79
Comment 4 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2013-02-25 22:42:01 PST
Comment on attachment 717835 [details] [diff] [review]
Add a warning

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 237319
User impact if declined: The removal of mostly unnecessary code is delayed. This patch adds an error console warning to give the one or two Web authors who use the feature an advance notice about the feature going away.
Testing completed (on m-c, etc.): Landed on m-c without problems.
Risk to taking this patch (and alternatives if risky): Extremely low risk (just logs a message).
String or UUID changes made by this patch: Adds one string. However, the string is an error console warning, so failure to translate is tolerable.
Comment 5 Masatoshi Kimura [:emk] 2013-02-27 00:32:46 PST
Are chunked response type going to be spec'ed and implemented by other browsers? It looks like it does not.
http://xhr.spec.whatwg.org/#interface-xmlhttprequest
I don't think it's a good idea to force Web developers to migrate once again.
Comment 6 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2013-02-27 05:27:39 PST
Good point. I'll follow up with a patch that recommends Web Sockets and Server-Sent Events but doesn't recommend chunked response.
Comment 7 bhavana bajaj [:bajaj] 2013-02-27 13:16:55 PST
CCing Axel here to weigh on the l10n impact . We think we should move fwd with the warning here .Pike what are the best options to deal with l10n here ?
Comment 8 Axel Hecht [:Pike] 2013-02-27 16:08:18 PST
My suggestion is to hard-code the string for aurora, and not expose it to l10n at all.
Comment 9 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2013-03-01 01:14:54 PST
Created attachment 719865 [details] [diff] [review]
Adjust warning text, make non-localizable
Comment 10 Olli Pettay [:smaug] 2013-03-01 01:59:07 PST
Comment on attachment 719865 [details] [diff] [review]
Adjust warning text, make non-localizable

(though, I hope chunked data will be added to XHR spec)
Comment 11 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2013-03-01 06:44:12 PST
Thanks.
https://hg.mozilla.org/integration/mozilla-inbound/rev/90c0a4c5a4b6
Comment 12 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2013-03-01 07:21:58 PST
Created attachment 719957 [details] [diff] [review]
Merged patch for aurora

This patch combines the two patches landed on inbound, hence, carrying forward r+.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 237319
User impact if declined: The removal of mostly unnecessary code is delayed. This patch adds an error console warning to give the one or two Web authors who use the feature an advance notice about the feature going away.
Testing completed (on m-c, etc.): Trivial patch. Has landed.
Risk to taking this patch (and alternatives if risky): Extremely low risk (just logs a message).
String or UUID changes made by this patch: None. The log message is non-localizable.
Comment 13 Ryan VanderMeulen [:RyanVM] 2013-03-01 15:49:59 PST
https://hg.mozilla.org/mozilla-central/rev/90c0a4c5a4b6
Comment 14 bhavana bajaj [:bajaj] 2013-03-01 16:32:27 PST
Comment on attachment 719957 [details] [diff] [review]
Merged patch for aurora

Thanks for work around done for the l10n here :) Low risk patch, approving on aurora
Comment 15 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2013-03-03 23:22:16 PST
Thanks. Landed on Aurora:
https://hg.mozilla.org/releases/mozilla-aurora/rev/feb9b4bac9ac
Comment 16 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2013-03-04 02:34:43 PST
Comment on attachment 719957 [details] [diff] [review]
Merged patch for aurora

[Approval Request Comment]
See comment 12.

Can we uplift all the way to beta considering that this is extremely low risk and has no l10n impact?
Comment 17 Lukas Blakk [:lsblakk] use ?needinfo 2013-03-04 13:25:47 PST
Comment on attachment 719957 [details] [diff] [review]
Merged patch for aurora

Approving since it's great to give 2 release warning (or close to it anyway) so let's get this into Beta 3 (ie: land to beta before tomorrow).
Comment 18 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2013-03-04 23:37:51 PST
Thanks. Landed on beta:
https://hg.mozilla.org/releases/mozilla-beta/rev/ede329b80bc5
Comment 19 Kohei Yoshino [:kohei] 2013-03-30 20:46:36 PDT
I've added this bug to the compatibility doc. Please correct the info if wrong.
https://developer.mozilla.org/en-US/docs/Site_Compatibility_for_Firefox_20

Note You need to log in before you can comment on or make changes to this bug.