Tab outline looks fuzzy on HiDPI displays w/layout.css.devPixelsPerPx = -1.0

RESOLVED DUPLICATE of bug 946987

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 946987
5 years ago
4 years ago

People

(Reporter: jimm, Unassigned)

Tracking

(Blocks: 2 bugs)

Trunk
x86_64
Windows 8
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29- affected, firefox30- affected)

Details

Comment 1

5 years ago
For what it's worth, every raster will need to be redone for high DPI. It seems more logical to me to group them all into one bug.
The misalignment shown in attachment 717840 [details], whereby the bottom of the tabs seems to "overlap" the toolbar by one pixel instead of exactly butting against it, does not occur when the window is maximized; it only happens (at least on my system, running with 150% scaling) in the non-maximized case.

Comment 3

5 years ago
layout.css.devPixelsPerPx is defaulted to -1.0
System DPI is set to 120dpi
Hi Res monitors

Issue started with the 22.0b1 update.

The default layout.css.devPixelsPerPx value of -1.0 gives equivalent appearance to the user window as value 1.25 (120dpi/96dpi). 

Menus and extension generated content match the user window at startup.
Menus and extensions do not resize as the user zooms (Ctrl+, Ctrl-). 
The default value of -1.0/1.25 causes improper scaling of images and icons in extensions and the add-on bar and expansion of all other content such as fonts.

Images are blurred or pixelated depending on the CSS image-rendering. 
This give the browser the same low quality appearance as when users accidentally zoom or when images are rendered without crisp edges. 

Not sure what the adoption rate for 120dpi is these days, but I expect this is going to affect a lot of extensions and result in another round of end user complaints about blurriness.

Updated

5 years ago
Blocks: 878288

Comment 4

4 years ago
I'm nominating this for tracking-firefox29 since this bug makes Australis's new tab design look quite bad on high DPI configurations. The rounded corners suffer from much more blur than the current square corners.
tracking-firefox29: --- → ?
For now, I am not sure we should track it. Ping us when you have an potential uplift for this.
status-firefox29: --- → affected
status-firefox30: --- → affected
tracking-firefox29: ? → -
tracking-firefox30: --- → -
(Reporter)

Comment 6

4 years ago
Australis is close to rolling out so.. lets dupe this over to the curved tabs bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 946987
You need to log in before you can comment on or make changes to this bug.