Mozilla crashing on Red Hat Rawhide Linux on some sites

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Martin Macok, Assigned: asa)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
When I enter this URL or click on the link, Mozilla crashes:
/usr/lib/mozilla/run-mozilla.sh: line 72:  1141 Neoprávn?ný p?ístup do pam?ti
(SIGSEGV)               $prog ${1+"$@"}

Red Hat 7.1 / Red Hat Rawhide (glibc-2.2.3, XFree86-4.1.0, gcc-2.96-85)
Mozilla 2001060713 (pre0.9.1-3) build for Athlon architecture.
(Reporter)

Comment 1

17 years ago
It also crashes when I sit at Red Hat Rawhide run Mozilla 2001060506 through
"ssh -X" from Debian testing. So it runs on Debian testing but is displayed on
my Red Hat Rawhide's display.

It doesn't crash when I sit at Debian testing and run it there directly.

Comment 2

17 years ago
Works for me using the 2001060708 build out of
http://ftp.mozilla.org/pub/mozilla/nightly/latest/ on Linux, which I believe is
off the trunk.

Updated

17 years ago
Keywords: crash

Comment 3

17 years ago
worksforme, linux-trunk build 2001060620

Comment 4

17 years ago
um, does it run at all if you run from redhat to redhat or from debian to 
redhat w/o params?

which xfree86 are you using (be very specific)? i'm guessing xfree4.1.0 in 
which case this is a dupe of us needing XIE and redhat xfree4.1.0 not including 
it.
(Reporter)

Comment 5

17 years ago
It does run on redhat and it does run on debian to redhat (through ssh -X).
(it crashes in both cases).
It does not crash when I run it on same debian testing (not through ssh -X). The
X version is XF4.1.0 too.

The Red Hat Rawhide:
XFree86-4.1.0-0.0.1
gdk-pixbuf-0.10.1-1
glibc-2.2.3-10
gcc-2.96-85
gtk+-1.2.10-1
kernel-2.4.5-0.2.9

And I rebuild Mozilla from sources (the version from you wanted XIE so I rebuilt
it and it seems now to not using XIE (?)). The target was
--target=athlon-redhat-linux ...

Now I did more sync to Red Hat Rawhide and I'm rebuilding 0.9.1 release here ...
I will submit new comment then ...
(Reporter)

Comment 6

17 years ago
I've just rebuild 0.9.1 on my Red Hat Rawhide, it runs well on all pages but
still crashes on reported URL.

Comment 7

17 years ago
wfm w2k nightly cvs build from yesterday.

reporter: can you run ./mozilla -g
so that we can get a stack trace?
(Reporter)

Comment 8

17 years ago
Gdk-CRITICAL **: file gdkwindow.c: line 716 (gdk_window_ref): assertion `window
!= NULL' failed.


Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 16331)]
0x414ed0fe in NSGetModule () from /usr/lib/mozilla/components/libgklayout.so
(Reporter)

Comment 9

17 years ago
and backtrace:
(gdb) bt
#0  0x414ed0fe in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#1  0x414c91d6 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#2  0x414c5b6c in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#3  0x414c57dd in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#4  0x414c567e in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#5  0x414c91d6 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#6  0x414c5b6c in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#7  0x414c57dd in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#8  0x414c567e in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#9  0x414c91d6 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#10 0x414a3010 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#11 0x414a2e46 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#12 0x414a2cab in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
... snip ...
   from /usr/lib/mozilla/components/libgklayout.so
#38 0x414f09cc in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#39 0x414bb277 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#40 0x414de4f4 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#41 0x414de68d in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#42 0x414de2ad in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#43 0x400dcabb in PL_HandleEvent () at eval.c:41
#44 0x400dc9c9 in PL_ProcessPendingEvents () at eval.c:41
#45 0x400ddb2b in nsEventQueueImpl::ProcessPendingEvents () at eval.c:41
#46 0x40746146 in NSGetModule ()
   from /usr/lib/mozilla/components/libwidget_gtk.so
#47 0x40745e95 in NSGetModule ()
   from /usr/lib/mozilla/components/libwidget_gtk.so
#48 0x40372fae in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#49 0x40374783 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#50 0x40374d49 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#51 0x40374efc in g_main_run () from /usr/lib/libglib-1.2.so.0
#52 0x402898f3 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#53 0x40746676 in NSGetModule ()
   from /usr/lib/mozilla/components/libwidget_gtk.so
#54 0x4072a352 in NSGetModule ()
   from /usr/lib/mozilla/components/libnsappshell.so
#55 0x0804fe8f in NS_CreateNativeAppSupport () at eval.c:41
#56 0x0805072f in main () at eval.c:41
#57 0x404bf5e7 in __libc_start_main (main=0x80505e4 <main>, argc=1, 
    ubp_av=0xbffff964, init=0x804be78 <_init>, fini=0x80524d4 <_fini>, 
    rtld_fini=0x4000e154 <_dl_fini>, stack_end=0xbffff95c)
    at ../sysdeps/generic/libc-start.c:129
(gdb) 
cc: blizzard in case he has any ideas.

does not crash my linux cvs trunk
Works on the trunk.  I don't intend to go back and fix 0.9.1.
Marking WORKSFORME, as this works on the trunk.

Gerv
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 13

17 years ago
I still got it crashing (20010610xx)

Maybe the bug is elsewhere in (current) Red Hat Rawhide ...
XFree86-4.1.0-0.0.1
glibc-2.2.3-10
gtk+-1.2.10-1
balí?ek gdk+ není nainstalován
kernel-2.4.5-0.2.9

I'm letting this status RESOLVED WORKSFORYOU :) but I will watch it and if this
problem will last after several upgrades to future Rawhide's and future Mozilla
builds and if the problem is not fixed then I will return and there will be Mr.
Reopen with me ...

Thanks for responds!
(Reporter)

Comment 14

17 years ago
that was
gdk-pixbuf-0.10.1-1

sorry ...
(Reporter)

Comment 15

17 years ago
So it crashes on http://www.mobil.cz/ and http://www.r-kw.de/ ...
(Reporter)

Updated

17 years ago
Summary: this URL crashes Mozilla-pre0.9.1-3 → Mozilla crashing on Red Hat Rawhide Linux on some sites

Updated

17 years ago
Summary: Mozilla crashing on Red Hat Rawhide Linux on some sites → this URL crashes Mozilla-pre0.9.1-3

Comment 16

17 years ago
SPAM:
Restoring "summary" line. I killed it somehow (how !?)... ;-(
Summary: this URL crashes Mozilla-pre0.9.1-3 → Mozilla crashing on Red Hat Rawhide Linux on some sites
(Reporter)

Comment 17

17 years ago
Created attachment 38987 [details]
gdb output - visiting mobil.cz and kolej.mff.cuni.cz
(Reporter)

Comment 18

17 years ago
I have tried to downgrade to gcc/cpp (I forgot libstdc++ downgrade) from Red
Hat7.1 and rebuild Mozilla
=> didn't help
 
I have tried to recompile XF4.1.0 with XIE enabled (I know Bug 83920)
+ recompiled GTK+
+ recompiled Mozilla
=> didn't help
 
So my current setup is:
kernel-2.4.5-0.2.9 (not so relevant)
glibc-2.2.3-10 (maybe?)
gtk+-1.2.10-1 (looks solid)
gcc-2.96-85 (downgrade didn't help)
libstdc++-2.96-85 (looks solid ? )
XFree86-4.1.0-0.0.1xie (mozilla is stable on Debian with X4.1)
 
Now I'm waiting for Rawhide update to sync with it and hope it helps.I have
tried to downgrade to gcc/cpp (I forgot libstdc++ downgrade) from Red Hat
7.1 and rebuild Mozilla
=> didn't help
 
I have tried to recompile XF4.1.0 with XIE enabled (I know Bug 83920)
+ recompiled GTK+
+ recompiled Mozilla
=> didn't help
 
So my current setup is:
kernel-2.4.5-0.2.9 (not so relevant)
glibc-2.2.3-10 (maybe?)
gtk+-1.2.10-1 (looks solid)
gcc-2.96-85 (downgrade didn't help)
libstdc++-2.96-85 (looks solid ? )
XFree86-4.1.0-0.0.1xie (mozilla is stable on Debian/unstable with XF4.1)
Please note that tor checked in the code that removes XIE + gdkpixbuf support
from Mozilla.
(Reporter)

Comment 20

17 years ago
I have tried today's nightly snapshot (20010619xx) and this stability problem is
not fixed :(

I will comment this
a) when I found something relevant
b) when I upgrade to future Rawhide
c) when I found it fixed

Comment 21

17 years ago
Please test if the issue does not occur with Xlib-toolkit:
Just compile your Zilla with 
--enable-toolkit=xlib
(Reporter)

Comment 22

17 years ago
I have tried:
BUILD_OFFICIAL=1 ./configure --prefix=%{_prefix} --enable-optimize \
        --disable-debug \
        --with-default-mozilla-five-home=/usr/lib/mozilla \
        --enable-strip-libs --disable-tests --disable-short-wchar \
        --enable-nspr-autoconf --with-extensions --without-mng \
        --enable-crypto \
        --enable-toolkit=xlib

but it tailed at the end with:nsWindowCreator.cpp
nsSigHandlers.cpp
showOSAlert.cpp
nsAppRunner.o: In function `InitializeProfileService(nsICmdLineService *)':
nsAppRunner.o(.text+0x1fe6): undefined reference to
`nsMPFileLocProvider::nsMPFileLocProvider(void)'
../../dist/bin/libxlibrgb.so: undefined reference to `NS_ERROR'
collect2: ld returned 1 exit status
make[1]: *** [mozilla-bin] Error 1
make: *** [install] Error 2

Today I found new Rawhide large update so I'm syncing and will return after new
tests under new rawhide (hope it's not broken).

Comment 23

17 years ago
xx@@@!!@@@xx... ;-(

my fault... ;-(

Add 
-- snip --
#include <nsDebug.h>
-- snip --
to mozilla/gfx/src/xlibrgb/xlibrgb.c - fix should be "in" soon...

Comment 24

17 years ago
Real workaround will be in bug 86291
(Reporter)

Comment 25

17 years ago
I have now build 20010620xx nightly (with gtk toolkit) on newer Rawhide:
kernel-2.4.5-0.4
XFree86-4.1.0-0.5.9
glibc-2.2.3-11
glib-1.2.10-2
gtk+-1.2.10-1

The result:
No crashing on http://www.kolej.mff.cuni.cz/~kr/odkazy.shtml.
No crashing on http://www.r-kw.de/, but crashing after refresh there.
With http://www.mobil.cz/ the mozilla has quit/close the window (no segfault).
(Reporter)

Comment 26

17 years ago
I have tried to build xlib version of 20010622xx but it failed (see Bug 86291).

So I have build with --enable-toolkit=xlib --disable-xprint but this version
doesn't run. (It just starts and exit() without any window).
(Reporter)

Comment 27

17 years ago
I have successfully built both xlib and QT versions.

Both are much more unstable than gtk.
(Reporter)

Comment 28

17 years ago
Still with Red Hat Linux release 20010619 (Rawhide):

mozilla 0.9.2 compiled for Athlon CPU:
http://zive.cz/ -> OK

mozilla current from CVS (20010702xx) compiled for i386:
http://zive.cz/ ->
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 5171)]
0x4105209a in NSGetModule () from
/opt/mozilla.cvs/mozilla/dist/bin/components/libgfx_gtk.so
(gdb) bt
#0  0x4105209a in NSGetModule () from
/opt/mozilla.cvs/mozilla/dist/bin/components/libgfx_gtk.so
#1  0x4105e65e in NSGetModule () from
/opt/mozilla.cvs/mozilla/dist/bin/components/libgfx_gtk.so
#2  0x415149f3 in NSGetModule () from
/opt/mozilla.cvs/mozilla/dist/bin/components/libgklayout.so
#3  0x4151565f in NSGetModule () from
/opt/mozilla.cvs/mozilla/dist/bin/components/libgklayout.so
...
[snip]
...#85 0x41506b04 in NSGetModule () from
/opt/mozilla.cvs/mozilla/dist/bin/components/libgklayout.so
#86 0x40134de3 in PL_HandleEvent () at eval.c:41
#87 0x401351f3 in PL_ProcessEventsBeforeID () at eval.c:41
#88 0x40c7d51f in NSGetModule () from
/opt/mozilla.cvs/mozilla/dist/bin/components/libwidget_gtk.so
#89 0x4010d66b in nsVoidArray::EnumerateForwards () at eval.c:41
#90 0x40c7d55c in NSGetModule () from
/opt/mozilla.cvs/mozilla/dist/bin/components/libwidget_gtk.so
#91 0x40c85d3e in NSGetModule () from
/opt/mozilla.cvs/mozilla/dist/bin/components/libwidget_gtk.so
#92 0x4033ed5f in gdk_event_dispatch () from /usr/lib/libgdk-1.2.so.0
#93 0x40372783 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#94 0x40372d49 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#95 0x40372efc in g_main_run () from /usr/lib/libglib-1.2.so.0
#96 0x402868f3 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#97 0x40c7d2a1 in NSGetModule () from
/opt/mozilla.cvs/mozilla/dist/bin/components/libwidget_gtk.so
#98 0x4072c742 in NSGetModule () from
/opt/mozilla.cvs/mozilla/dist/bin/components/libnsappshell.so
#99 0x0805177d in NS_CreateNativeAppSupport () at eval.c:41
#100 0x08052069 in main () at eval.c:41
#101 0x404ba5c7 in __libc_start_main (main=0x8051f34 <main>, argc=1,
ubp_av=0xbffff804, init=0x804c114 <_init>, fini=0x8053f58 <_fini>,
rtld_fini=0x4000ca04 <_dl_fini>, stack_end=0xbffff7fc) at
../sysdeps/generic/libc-start.c:129
in eval.c
(gdb)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.